summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-04-06 17:56:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-04-06 18:27:14 +0200
commit4357145be95494c8696a97d33f73e4af0109f817 (patch)
treee6e236bd7f162c7397034dda6392e4c79237e200 /app-emacs
parentwww-client/firefox: arm64 build fix for 124.0.2 (diff)
downloadgentoo-4357145be95494c8696a97d33f73e4af0109f817.tar.gz
gentoo-4357145be95494c8696a97d33f73e4af0109f817.tar.bz2
gentoo-4357145be95494c8696a97d33f73e4af0109f817.zip
app-emacs/corfu: bump to 1.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/corfu/Manifest1
-rw-r--r--app-emacs/corfu/corfu-1.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/corfu/Manifest b/app-emacs/corfu/Manifest
index 6d8aaf95a638..4b85b9a7c190 100644
--- a/app-emacs/corfu/Manifest
+++ b/app-emacs/corfu/Manifest
@@ -1 +1,2 @@
DIST corfu-1.2.tar.gz 49307 BLAKE2B 69dbc020671ac83a8c858030079f53eb2dd16a4b8a418386f310b56ffc4bc74da87a1f87355daf615eb120962186ae2210b9c1237d62e282b4436cb8433e959e SHA512 b1528e71bc03a5a06428e58009ea4e1bd68d9bc0f38181da910f5a633b35545642dc9fe8e2e39316f2b9bce7c3fc61418225f8243fb86ec2c2d96f7c0e88900b
+DIST corfu-1.3.tar.gz 49907 BLAKE2B 18fbd99fa6d744bf3ad82abf647447770916b84d15ef1a44d4cdc406975ec0c035e75fc5234ce6e13f21840567ad1d574acd25a774585b42522491cdefa93bd6 SHA512 c21962572a101b6e5dd654ac058dd534b450840a97b6d4029b191ddce10a9c6bfc9e631e969ce15789e4fb71ccad66dde509a4c1a7f30a2669327ee84c706987
diff --git a/app-emacs/corfu/corfu-1.3.ebuild b/app-emacs/corfu/corfu-1.3.ebuild
new file mode 100644
index 000000000000..d8351fe993cc
--- /dev/null
+++ b/app-emacs/corfu/corfu-1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion Overlay Region FUnction"
+HOMEPAGE="https://github.com/minad/corfu/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}