summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-13 03:13:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-13 03:13:31 +0100
commit48eee5f6377f1105a9a12899e730cc5fcaf8b05d (patch)
tree1cac9f50d79a619ee3f3c55016e4b31e822d8263 /app-emacs
parentapp-emacs/org-mode: bump to 9.6.1 (diff)
downloadgentoo-48eee5f6377f1105a9a12899e730cc5fcaf8b05d.tar.gz
gentoo-48eee5f6377f1105a9a12899e730cc5fcaf8b05d.tar.bz2
gentoo-48eee5f6377f1105a9a12899e730cc5fcaf8b05d.zip
app-emacs/graphql: bump to 0.1.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/graphql/Manifest1
-rw-r--r--app-emacs/graphql/graphql-0.1.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/graphql/Manifest b/app-emacs/graphql/Manifest
index b6e9ea7184ad..d21a1d91ce98 100644
--- a/app-emacs/graphql/Manifest
+++ b/app-emacs/graphql/Manifest
@@ -1 +1,2 @@
DIST graphql-0.1.1.tar.gz 6021 BLAKE2B 62755fda880042e00942acc6dbf98219521c92d052eeb0c584e8bb83ae8fdcea46185270f5dff8c89762d11b409e31b42d4ae62ab6831b04437ac0de517f442e SHA512 53f4c8b70be07f38b3554c4488a98ccdb956a68585955c7afd9df52d9d39cfaf7cc0efcadae1f42099495b8729851d089cd03d4570ed2a91a3354dd19f12d5bb
+DIST graphql-0.1.2.tar.gz 6231 BLAKE2B 55b121b3040b55c8c690637ef5fb034c66e2837e1c22c3e1b37911cc7c26741adb15344f861195f8156c33e844a950e4e6fe97acc502321a561b9c7b249c7aeb SHA512 45b1b72f4fafd884633dab3b464079ed7c80e671b4d0a5f26dc57f058177e5f54ed453710d36e02062d80abeee5e0215aff395063f8e3124646ffb05bdeff8c5
diff --git a/app-emacs/graphql/graphql-0.1.2.ebuild b/app-emacs/graphql/graphql-0.1.2.ebuild
new file mode 100644
index 000000000000..1ea6269125e9
--- /dev/null
+++ b/app-emacs/graphql/graphql-0.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+[[ "${PV}" == 0.1.2 ]] && H=67237f284f2dfb94f3cfba672ff64a37e1cb860f
+
+inherit elisp
+
+DESCRIPTION="GraphQL utilities"
+HOMEPAGE="https://github.com/vermiculus/graphql.el/"
+SRC_URI="https://github.com/vermiculus/graphql.el/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+# Tries to download emake tool on the fly
+RESTRICT="test"
+
+src_prepare() {
+ # Avoid examples which would require circular dependencies
+ rm -f ${PN}-examples.el || die
+
+ default
+}