summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-06 20:44:32 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-06 21:51:33 +0200
commit51183cd7a1eb8a49aeebf76f91bbdfbaac8e3077 (patch)
tree52d7a084507d86febad79aafd85996297797f76a /app-emacs
parentapp-emacs/elixir-mode: minor tweaks (diff)
downloadgentoo-51183cd7a1eb8a49aeebf76f91bbdfbaac8e3077.tar.gz
gentoo-51183cd7a1eb8a49aeebf76f91bbdfbaac8e3077.tar.bz2
gentoo-51183cd7a1eb8a49aeebf76f91bbdfbaac8e3077.zip
app-emacs/parseclj: minor tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/parseclj/parseclj-1.1.1.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/app-emacs/parseclj/parseclj-1.1.1.ebuild b/app-emacs/parseclj/parseclj-1.1.1.ebuild
index 093bb113f3b6..e17fcc8ef904 100644
--- a/app-emacs/parseclj/parseclj-1.1.1.ebuild
+++ b/app-emacs/parseclj/parseclj-1.1.1.ebuild
@@ -7,20 +7,22 @@ inherit elisp
DESCRIPTION="Clojure Parser for Emacs Lisp"
HOMEPAGE="https://github.com/clojure-emacs/parseclj/"
-SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/clojure-emacs/${PN}.git"
+else
+ SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ~x86"
+fi
LICENSE="GPL-3+"
-KEYWORDS="amd64 ~x86"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="test? ( app-emacs/ert-runner )"
DOCS=( CHANGELOG.md DESIGN.md README.md )
SITEFILE="50${PN}-gentoo.el"
-src_test() {
- ert-runner -L . -L test --reporter ert+duration --script test || die
-}
+elisp-enable-tests ert-runner test