summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-27 00:55:57 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-27 01:05:27 +0100
commit73cc7110fe1f2bf40e3373a5ee3055da27db7cf3 (patch)
tree45052b4ea276683a85cb62be99979797104cbffd /app-emacs
parentapp-emacs/elpy: enable python 3.11 (diff)
downloadgentoo-73cc7110fe1f2bf40e3373a5ee3055da27db7cf3.tar.gz
gentoo-73cc7110fe1f2bf40e3373a5ee3055da27db7cf3.tar.bz2
gentoo-73cc7110fe1f2bf40e3373a5ee3055da27db7cf3.zip
app-emacs/pymacs: enable python 3.11
Closes: https://bugs.gentoo.org/896536 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/pymacs/pymacs-0.26-r3.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/app-emacs/pymacs/pymacs-0.26-r3.ebuild b/app-emacs/pymacs/pymacs-0.26-r3.ebuild
index 648ad8f83a57..b17150d95bb4 100644
--- a/app-emacs/pymacs/pymacs-0.26-r3.ebuild
+++ b/app-emacs/pymacs/pymacs-0.26-r3.ebuild
@@ -3,26 +3,29 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9,10} )
+# Can not use "DISTUTILS_USE_PEP517" because we need "DISTUTILS_IN_SOURCE_BUILD".
DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python3_{9..11} )
inherit elisp distutils-r1
DESCRIPTION="A tool that allows both-side communication between Python and Emacs Lisp"
HOMEPAGE="https://www.emacswiki.org/emacs/PyMacs"
-SRC_URI="https://github.com/dgentry/${PN^}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/dgentry/${PN^}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${P^}
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 arm ~hppa ~ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc"
-BDEPEND="doc? (
+BDEPEND="
+ doc? (
>=dev-python/docutils-0.7
virtual/latex-base
- )"
-
-S="${WORKDIR}/${P^}"
+ )
+"
SITEFILE="50${PN}-gentoo.el"
@@ -35,6 +38,7 @@ python_configure() {
# called once
python_compile_all() {
elisp_src_compile
+
if use doc; then
VARTEXFONTS="${T}"/fonts emake RST2LATEX=rst2latex.py pymacs.pdf
fi
@@ -42,7 +46,10 @@ python_compile_all() {
python_install_all() {
elisp_src_install
+
distutils-r1_python_install_all
+
dodoc pymacs.rst
+
use doc && dodoc pymacs.pdf
}