summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-08 18:58:58 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-08 20:34:42 +0100
commit90d8e86c71554da135f19501449e643577cafb20 (patch)
treebc21f1a8e008087a4ff108f313a0395c4aa429a3 /app-emacs
parentapp-emacs/transient: bump to 0.7.9 (diff)
downloadgentoo-90d8e86c71554da135f19501449e643577cafb20.tar.gz
gentoo-90d8e86c71554da135f19501449e643577cafb20.tar.bz2
gentoo-90d8e86c71554da135f19501449e643577cafb20.zip
app-emacs/kaolin-themes: bump to 1.7.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/kaolin-themes/Manifest1
-rw-r--r--app-emacs/kaolin-themes/kaolin-themes-1.7.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/kaolin-themes/Manifest b/app-emacs/kaolin-themes/Manifest
index 385504d916ec..59c20c1eee66 100644
--- a/app-emacs/kaolin-themes/Manifest
+++ b/app-emacs/kaolin-themes/Manifest
@@ -1 +1,2 @@
DIST kaolin-themes-1.7.0.tar.gz 48024 BLAKE2B 01128417a5808364d399ce22cd74da74619b7a592060f77fcf46ebd33cd23f69aa62d45b31f87c98f95f1a2a306c597424be7996867b1979be1aa46883cdb61b SHA512 e640a4375d252ae04b53df71795125e2088b680c4193ae16c0544903e69077fc2185edadd6866fafa6f401aab33d405ee4435bfadd7e06b84af52a456becd379
+DIST kaolin-themes-1.7.1.tar.gz 47939 BLAKE2B 7481334c333cd3d1cfc9812f033607760ed89baacf985c83a800137d0cdd9a6269a72be6c309bc00bb368fe83f4c1a91de2fc557050c85ea02c8f28500ef26d6 SHA512 f297c52a987e38041abd58e5d8a0868e8dd32f351e02288ec1f62e7cf4f3adb853308c2f1200a4f5a81f232bdeec6507243cfa5151579cfe2c24c6ce0b0295b1
diff --git a/app-emacs/kaolin-themes/kaolin-themes-1.7.1.ebuild b/app-emacs/kaolin-themes/kaolin-themes-1.7.1.ebuild
new file mode 100644
index 000000000000..751e6e68f8a5
--- /dev/null
+++ b/app-emacs/kaolin-themes/kaolin-themes-1.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Set of eye pleasing themes for GNU Emacs"
+HOMEPAGE="https://github.com/ogdenwebb/emacs-kaolin-themes"
+
+MY_PN="emacs-${PN}"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URL="https://github.com/ogdenwebb/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/ogdenwebb/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+RDEPEND="app-emacs/autothemer"
+BDEPEND="${RDEPEND}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el themes/*.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc themes/*.el themes/*.elc
+ elisp-make-site-file "${SITEFILE}"
+}