summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-11-08 20:39:24 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-11-08 20:58:48 +0100
commitd511e448af9f56b23b73095b33198f51adf43a6f (patch)
treeebcfe9884aa6bdc0569a12a5087de80b0f14fbbb /app-emacs
parentdev-util/cargo-ebuild: filter out -flto (diff)
downloadgentoo-d511e448af9f56b23b73095b33198f51adf43a6f.tar.gz
gentoo-d511e448af9f56b23b73095b33198f51adf43a6f.tar.bz2
gentoo-d511e448af9f56b23b73095b33198f51adf43a6f.zip
app-emacs/apheleia: new package; add 3.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/apheleia/Manifest1
-rw-r--r--app-emacs/apheleia/apheleia-3.0.ebuild20
-rw-r--r--app-emacs/apheleia/files/50apheleia-gentoo.el7
-rw-r--r--app-emacs/apheleia/metadata.xml20
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/apheleia/Manifest b/app-emacs/apheleia/Manifest
new file mode 100644
index 000000000000..169de33f62d6
--- /dev/null
+++ b/app-emacs/apheleia/Manifest
@@ -0,0 +1 @@
+DIST apheleia-3.0.tar.gz 36988 BLAKE2B 49e9231e1cddd73ff353512ac29e6b1491bc2cad0985a12677743acb1514b827c8462e6b40912367472adf9d0be12150541162d3106e8e510650c3d70b0bf598 SHA512 19304feda4d3570e68184639a3969f2102765836324db9e1de958e63cf49614a62672df83c21420df92671217ee05630e0c0e0d57cd5ff75eba50a080f0dfde9
diff --git a/app-emacs/apheleia/apheleia-3.0.ebuild b/app-emacs/apheleia/apheleia-3.0.ebuild
new file mode 100644
index 000000000000..7ba2f55e8c2c
--- /dev/null
+++ b/app-emacs/apheleia/apheleia-3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="Reformat GNU Emacs buffers stably without moving point"
+HOMEPAGE="https://github.com/radian-software/apheleia/"
+SRC_URI="https://github.com/radian-software/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md CHANGELOG.md )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/apheleia/files/50apheleia-gentoo.el b/app-emacs/apheleia/files/50apheleia-gentoo.el
new file mode 100644
index 000000000000..2076d504530a
--- /dev/null
+++ b/app-emacs/apheleia/files/50apheleia-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'apheleia-format-buffer "apheleia"
+ "Run code formatter asynchronously on current buffer, preserving point." t)
+(autoload 'apheleia-global-mode "apheleia"
+ "Global minor mode for reformatting code on save without moving point." t)
+(autoload 'apheleia-mode "apheleia"
+ "Minor mode for reformatting code on save without moving point." t)
diff --git a/app-emacs/apheleia/metadata.xml b/app-emacs/apheleia/metadata.xml
new file mode 100644
index 000000000000..490f5620cf49
--- /dev/null
+++ b/app-emacs/apheleia/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Apheleia is an Emacs Lisp package which allows you to reformat a buffer
+ without moving point. This solves the usual problem of running a tool like
+ Prettier or Black on before-save-hook, namely that it resets point to the
+ beginning of the buffer. Apheleia maintains the position of point relative
+ to its surrounding text even if the buffer is modified by the reformatting.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/radian-software/apheleia/issues/</bugs-to>
+ <remote-id type="github">radian-software/apheleia</remote-id>
+ </upstream>
+</pkgmetadata>