summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-20 19:48:28 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-20 20:30:53 +0100
commite6118f13ad383a0e33f637e1df60774c23a8cdeb (patch)
tree1092507c511623c3a33c8a56df66534cdb521cd8 /app-emacs
parentapp-emacs/org-mode: bump to 9.6.21 (diff)
downloadgentoo-e6118f13ad383a0e33f637e1df60774c23a8cdeb.tar.gz
gentoo-e6118f13ad383a0e33f637e1df60774c23a8cdeb.tar.bz2
gentoo-e6118f13ad383a0e33f637e1df60774c23a8cdeb.zip
app-emacs/compat: bump to 29.1.4.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/compat/Manifest1
-rw-r--r--app-emacs/compat/compat-29.1.4.5.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index 6a2a35f1733c..6b3599468d65 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1 +1,2 @@
DIST compat-29.1.4.4.tar.gz 129900 BLAKE2B 460aa851cbb341290cef250e70bf501a30cd174cd135ea429f7a3aa71597804c802c4225424072b49b4b7726b6e31c0ba36e6c0a4e154a2048075697656c2d31 SHA512 b6ecfde494dc5b1e96ed6d6cb450b3b647761c30128859a03d0d054e633227dd0714dd4ee8d39cf9eb4d702e9f08feaba41c39d91e6871724c458173e16d9e89
+DIST compat-29.1.4.5.tar.gz 130079 BLAKE2B 84b3293bec535d7f653d0aa3fac069e230c030ccf809d0a606b068d9d663e078274d15d57ca56fc180208de69ae4fee554fbc3d5e8c78394789ee756665e980f SHA512 9682224a1ab5238c7f584121652c55df257fd050279e8356632b2aafef4045dc89b2dfd20cf8f5030dda1d96db40c993cdc3ac0efd0263d23beee8310def0849
diff --git a/app-emacs/compat/compat-29.1.4.5.ebuild b/app-emacs/compat/compat-29.1.4.5.ebuild
new file mode 100644
index 000000000000..0de9f6e50e90
--- /dev/null
+++ b/app-emacs/compat/compat-29.1.4.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Compatibility libraries for Emacs"
+HOMEPAGE="https://github.com/emacs-compat/compat/
+ https://git.sr.ht/~pkal/compat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-compat/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ sys-apps/texinfo
+"
+
+ELISP_TEXINFO="${PN}.texi"
+
+src_compile() {
+ emake compile "${PN}.info"
+}
+
+src_test() {
+ local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
+ if [[ "${has_json}" != t ]] ; then
+ local line
+ while read line ; do
+ ewarn "${line}"
+ done <<-EOF
+ Your current Emacs version does not support native JSON parsing,
+ which is required for running tests of ${CATEGORY}/${PN}.
+ Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
+ to select that version.
+ EOF
+ else
+ emake test
+ fi
+}