summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@gentoo.org>2025-01-07 20:56:24 +0100
committerArsen Arsenović <arsen@gentoo.org>2025-01-07 21:10:50 +0100
commitf886d86a8aea1de5f06f02550ec7bde9eb0a4c48 (patch)
tree7f254575c480de1c0b6876675baec91c19f48988 /app-emacs
parentdev-lang/ada-bootstrap: strip unsupported CXXFLAGS too (diff)
downloadgentoo-f886d86a8aea1de5f06f02550ec7bde9eb0a4c48.tar.gz
gentoo-f886d86a8aea1de5f06f02550ec7bde9eb0a4c48.tar.bz2
gentoo-f886d86a8aea1de5f06f02550ec7bde9eb0a4c48.zip
app-emacs/gruvbox-theme: add 1.30.2
Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gruvbox-theme/Manifest1
-rw-r--r--app-emacs/gruvbox-theme/files/50gruvbox-theme-gentoo.el2
-rw-r--r--app-emacs/gruvbox-theme/gruvbox-theme-1.30.2.ebuild31
3 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/gruvbox-theme/Manifest b/app-emacs/gruvbox-theme/Manifest
index e519d6cd261e..465449ed166d 100644
--- a/app-emacs/gruvbox-theme/Manifest
+++ b/app-emacs/gruvbox-theme/Manifest
@@ -1 +1,2 @@
DIST gruvbox-theme-1.30.1.tar.gz 2849739 BLAKE2B 1d9c005b65237431f62ccda120b3adf5bed66c2238fcab263d6c18cc79b79553fbfdd04fb56cb053990b2c09fdd8f5a607d7b2a86c1164ec3a6ee1134de43b49 SHA512 52d20729c4bcc4677bb4aa9fa14a95bb3ae9a5729e70d93817030ebb3235d7e7d72562e34ab74c8c0e8c03183ae3711ef50d04160e04608bc9968d651c40f1d8
+DIST gruvbox-theme-1.30.2.tar.gz 2849853 BLAKE2B 7afd464b1108c0d1dbe5dc35f460d68b25ec3eb01f06e3b99a9f9c2d3e7bb276ece8394886f319eb43e2501cdc8be75a65fc141ec0840940ef4a9de9d0fb1883 SHA512 ddfcf963503d0958862ee99f0e799edff2d43e97f7b56e585f3d8a3d377d7a3e66eb8d5c719569a3d016d20173ddafb02771dcceb4a2878d4fad9ea1e50aab86
diff --git a/app-emacs/gruvbox-theme/files/50gruvbox-theme-gentoo.el b/app-emacs/gruvbox-theme/files/50gruvbox-theme-gentoo.el
index 7e3219a1f424..070b1fcfb36b 100644
--- a/app-emacs/gruvbox-theme/files/50gruvbox-theme-gentoo.el
+++ b/app-emacs/gruvbox-theme/files/50gruvbox-theme-gentoo.el
@@ -1,2 +1,4 @@
;;; app-emacs/gruvbox-theme site configuration -*- lexical-binding: t; -*-
(add-to-list 'load-path "@SITELISP@")
+(when (boundp 'custom-theme-load-path)
+ (add-to-list 'custom-theme-load-path "@SITELISP@"))
diff --git a/app-emacs/gruvbox-theme/gruvbox-theme-1.30.2.ebuild b/app-emacs/gruvbox-theme/gruvbox-theme-1.30.2.ebuild
new file mode 100644
index 000000000000..769f543e160c
--- /dev/null
+++ b/app-emacs/gruvbox-theme/gruvbox-theme-1.30.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Gruvbox is a retro groove color scheme, now in Emacs"
+HOMEPAGE="https://github.com/greduan/emacs-theme-gruvbox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/greduan/emacs-theme-gruvbox.git"
+else
+ SRC_URI="https://github.com/greduan/emacs-theme-gruvbox/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/emacs-theme-gruvbox-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/autothemer-0.2
+"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"