summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-09-15 15:38:09 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-09-15 15:38:51 +0200
commitf745184b688cd5a864915a363747537bc8928afb (patch)
tree88039aceee92562f53176e204e099a7778cbd566 /app-emulation/86Box
parentsys-apps/cpuid: add 20240912 (diff)
downloadgentoo-f745184b688cd5a864915a363747537bc8928afb.tar.gz
gentoo-f745184b688cd5a864915a363747537bc8928afb.tar.bz2
gentoo-f745184b688cd5a864915a363747537bc8928afb.zip
app-emulation/86Box: add 4.2.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-emulation/86Box')
-rw-r--r--app-emulation/86Box/86Box-4.2.1.ebuild73
-rw-r--r--app-emulation/86Box/Manifest1
2 files changed, 74 insertions, 0 deletions
diff --git a/app-emulation/86Box/86Box-4.2.1.ebuild b/app-emulation/86Box/86Box-4.2.1.ebuild
new file mode 100644
index 000000000000..1be46ab052ba
--- /dev/null
+++ b/app-emulation/86Box/86Box-4.2.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Emulator of x86-based machines based on PCem"
+HOMEPAGE="https://github.com/86Box/86Box"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="experimental +fluidsynth +munt new-dynarec +openal +qt6 +threads"
+
+DEPEND="
+ app-emulation/faudio
+ dev-libs/libevdev
+ media-libs/freetype:2=
+ media-libs/libpng:=
+ media-libs/libsdl2
+ media-libs/openal
+ media-libs/rtmidi
+ net-libs/libslirp
+ sys-libs/zlib
+ qt6? ( x11-libs/libXi )
+"
+
+RDEPEND="
+ ${DEPEND}
+ fluidsynth? ( media-sound/fluidsynth )
+ munt? ( media-libs/munt-mt32emu )
+ openal? ( media-libs/openal )
+ qt6? (
+ dev-qt/qtbase:6[gui,network,opengl,widgets]
+ dev-qt/qttranslations:6
+ kde-frameworks/extra-cmake-modules
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ # LTO needs to be filtered
+ # See https://bugs.gentoo.org/854507
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ local mycmakeargs=(
+ -DCPPTHREADS="$(usex threads)"
+ -DDEV_BRANCH="$(usex experimental)"
+ -DDYNAREC="ON"
+ -DMUNT_EXTERNAL="$(usex munt)"
+ -DFLUIDSYNTH="$(usex fluidsynth)"
+ -DMINITRACE="OFF"
+ -DMUNT="$(usex munt)"
+ -DNEW_DYNAREC="$(usex new-dynarec)"
+ -DOPENAL="$(usex openal)"
+ -DPREFER_STATIC="OFF"
+ -DRTMIDI="ON"
+ -DQT="$(usex qt6)"
+ -DRELEASE="ON"
+ $(usex qt6 '-DUSE_QT6=ON' '')
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "In order to use 86Box, you will need some roms for various emulated systems."
+ elog "See https://github.com/86Box/roms for more information."
+}
diff --git a/app-emulation/86Box/Manifest b/app-emulation/86Box/Manifest
index 9e7e002eefc1..ba6834853309 100644
--- a/app-emulation/86Box/Manifest
+++ b/app-emulation/86Box/Manifest
@@ -1 +1,2 @@
+DIST 86Box-4.2.1.tar.gz 5320110 BLAKE2B cf3379dffcd93f9c317c02b91ba5772a54abcc0e67ca588b22e07d5b221d40db4c0a54dcdd30cd1e2dd46a808393a9e09db917fe9445cbfb56ff9675d4eb35d9 SHA512 ed8e90f68318d163c39202479d654859d4d74b6fdffd47cfcba6b0393965265615aa008b02cfd04ac8cafc2f38cead53ed5d6071cabd4b96eba91ec805c5a2df
DIST 86Box-4.2.tar.gz 5297797 BLAKE2B a1933aaaa501f54539b05436a2c0f91454a253a0f1a98bbea165f0a11188c3f5a55af58dbbc53387fec1be853c5bcacb510d74f5a98a47d7821ab0f257f93f82 SHA512 af817d2fdf385e761bf98728633f6c5cf4feca5e39d7323d7825f2f6a11c42882009005d2c50fded19fb2615eff8679b010ab85fd38b7cabc08408e2c447baed