summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-07-05 13:52:15 +0200
committerPacho Ramos <pacho@gentoo.org>2017-07-05 14:27:01 +0200
commit819c3594ce2c0ab7159d23eb239ab225146b407c (patch)
treeb7c9e264cea898444a7453d2147ecdb66978c63e /app-emulation/bochs/bochs-2.6.9.ebuild
parentdev-java/java-gnome: Remove last-rited pkg, #562416 (diff)
downloadgentoo-819c3594ce2c0ab7159d23eb239ab225146b407c.tar.gz
gentoo-819c3594ce2c0ab7159d23eb239ab225146b407c.tar.bz2
gentoo-819c3594ce2c0ab7159d23eb239ab225146b407c.zip
app-emulation/bochs: Version bump, disable wxwidgets support like other distributions did long time ago (due to unresolved bugs with wxGTK newer than 2.6, it also doesn't look to be compatible at all with 3.0 (#563960)
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-emulation/bochs/bochs-2.6.9.ebuild')
-rw-r--r--app-emulation/bochs/bochs-2.6.9.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/app-emulation/bochs/bochs-2.6.9.ebuild b/app-emulation/bochs/bochs-2.6.9.ebuild
new file mode 100644
index 000000000000..1fbf6c61aec6
--- /dev/null
+++ b/app-emulation/bochs/bochs-2.6.9.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="LGPL-ed pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+IUSE="3dnow avx debugger doc gdb ncurses readline svga sdl +smp vnc X +x86-64"
+REQUIRED_USE="
+ avx? ( x86-64 )
+ gdb? ( !debugger !smp )
+ debugger? ( !gdb )
+"
+
+RDEPEND="
+ X? ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm )
+ sdl? ( media-libs/libsdl )
+ svga? ( media-libs/svgalib )
+ readline? ( sys-libs/readline:= )
+ ncurses? ( sys-libs/ncurses:= )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-sgml-utils )
+ X? ( x11-proto/xproto )
+ sys-apps/sed
+ >=app-text/opensp-1.5
+"
+
+src_prepare() {
+ default
+ sed -i "s:^docdir.*:docdir = ${EPREFIX}/usr/share/doc/${PF}:" \
+ Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --enable-all-optimizations \
+ --enable-idle-hack \
+ --enable-cdrom \
+ --enable-clgd54xx \
+ --enable-cpu-level=6 \
+ --enable-disasm \
+ --enable-e1000 \
+ --enable-gameport \
+ --enable-iodebug \
+ --enable-monitor-mwait \
+ --enable-ne2000 \
+ --enable-plugins \
+ --enable-pci \
+ --enable-pnic \
+ --enable-raw-serial \
+ --enable-sb16=linux \
+ --enable-usb \
+ --enable-usb-ohci \
+ --enable-usb-xhci \
+ --prefix=/usr \
+ --with-nogui \
+ --without-wx \
+ $(use_enable 3dnow) \
+ $(use_enable avx) \
+ $(use_enable debugger) \
+ $(use_enable doc docbook) \
+ $(use_enable gdb gdb-stub) \
+ $(use_enable readline) \
+ $(use_enable smp) \
+ $(use_enable x86-64) \
+ $(use_with ncurses term) \
+ $(use_with sdl) \
+ $(use_with svga) \
+ $(use_with vnc rfb) \
+ $(use_with X x) \
+ $(use_with X x11) \
+ ${myconf}
+}