summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-12-23 15:11:31 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-12-23 15:11:58 -0600
commitdcd9d8b9a9d4e5e2f1fb808c4bd582ac98e07742 (patch)
treeb5081fea23908d7df925c0a7bf848e3544cd3fa8 /app-emulation/cloud-init/cloud-init-0.7.8-r2.ebuild
parentnet-analyzer/nmap: Version bump (bug #603542). (diff)
downloadgentoo-dcd9d8b9a9d4e5e2f1fb808c4bd582ac98e07742.tar.gz
gentoo-dcd9d8b9a9d4e5e2f1fb808c4bd582ac98e07742.tar.bz2
gentoo-dcd9d8b9a9d4e5e2f1fb808c4bd582ac98e07742.zip
app-emulation/cloud-init: fixing missing dep on cheetah
Package-Manager: portage-2.3.0 RepoMan-Options: --force
Diffstat (limited to 'app-emulation/cloud-init/cloud-init-0.7.8-r2.ebuild')
-rw-r--r--app-emulation/cloud-init/cloud-init-0.7.8-r2.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/app-emulation/cloud-init/cloud-init-0.7.8-r2.ebuild b/app-emulation/cloud-init/cloud-init-0.7.8-r2.ebuild
new file mode 100644
index 000000000000..b2c892ea6651
--- /dev/null
+++ b/app-emulation/cloud-init/cloud-init-0.7.8-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1 eutils multilib systemd
+
+DESCRIPTION="cloud initialisation magic"
+HOMEPAGE="https://launchpad.net/cloud-init"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+CDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/cheetah[$(python_gen_usedep 'python2_7')]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${CDEPEND}
+ >=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/hacking[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ sys-apps/iproute2
+ sys-fs/growpart
+ virtual/logger
+"
+
+PATCHES=( "${FILESDIR}/cloud-init-0.7.8-gentooinit.patch" )
+
+python_prepare_all() {
+ sed -i '/^argparse/d' requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ emake test
+}
+
+python_install() {
+ distutils-r1_python_install "--init-system=sysvinit_openrc"
+}
+
+python_install_all() {
+ keepdir /etc/cloud
+
+ distutils-r1_python_install_all
+
+ chmod +x "${D}"/etc/init.d/cloud-config
+ chmod +x "${D}"/etc/init.d/cloud-final
+ chmod +x "${D}"/etc/init.d/cloud-init
+ chmod +x "${D}"/etc/init.d/cloud-init-local
+
+ insinto /etc/cloud/templates
+ doins "${FILESDIR}/hosts.gentoo.tmpl"
+ insinto /etc/cloud
+ doins "${FILESDIR}/cloud.cfg"
+
+ systemd_dounit "${S}"/systemd/cloud-config.service
+ systemd_dounit "${S}"/systemd/cloud-config.target
+ systemd_dounit "${S}"/systemd/cloud-final.service
+ systemd_dounit "${S}"/systemd/cloud-init-local.service
+ systemd_dounit "${S}"/systemd/cloud-init.service
+}
+
+pkg_postinst() {
+ elog "cloud-init-local needs to be run in the boot runlevel because it"
+ elog "modifies services in the default runlevel. When a runlevel is started"
+ elog "it is cached, so modifications that happen to the current runlevel"
+ elog "while you are in it are not acted upon."
+}