summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2017-09-13 17:09:00 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2017-09-13 17:09:00 -0400
commit32929e0ff9e6c8d40e0a2cd4e2d4a50ef15a54f2 (patch)
treee57d2a319da4b7aa5cb93083427134bf003d4f9a /app-emulation/wine-any
parentapp-emulation/wine-d3d9: Fix xdg-utils.eclass migration (diff)
downloadgentoo-32929e0ff9e6c8d40e0a2cd4e2d4a50ef15a54f2.tar.gz
gentoo-32929e0ff9e6c8d40e0a2cd4e2d4a50ef15a54f2.tar.bz2
gentoo-32929e0ff9e6c8d40e0a2cd4e2d4a50ef15a54f2.zip
app-emulation/wine-any: Fix xdg-utils.eclass migration
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-emulation/wine-any')
-rw-r--r--app-emulation/wine-any/wine-any-2.0.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.1.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.10.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.11.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.12.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.13.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.14.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.15.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.16.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.2.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.3.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.4.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.5.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.6.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.7.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.8.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-2.9.ebuild6
-rw-r--r--app-emulation/wine-any/wine-any-9999.ebuild6
18 files changed, 54 insertions, 54 deletions
diff --git a/app-emulation/wine-any/wine-any-2.0.ebuild b/app-emulation/wine-any/wine-any-2.0.ebuild
index 41b9581e84a3..68c668125366 100644
--- a/app-emulation/wine-any/wine-any-2.0.ebuild
+++ b/app-emulation/wine-any/wine-any-2.0.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -578,7 +578,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -611,5 +611,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.1.ebuild b/app-emulation/wine-any/wine-any-2.1.ebuild
index c13161d775a5..8562bece7338 100644
--- a/app-emulation/wine-any/wine-any-2.1.ebuild
+++ b/app-emulation/wine-any/wine-any-2.1.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -578,7 +578,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -611,5 +611,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.10.ebuild b/app-emulation/wine-any/wine-any-2.10.ebuild
index 2d6272832a64..bb2c5ea4bf1c 100644
--- a/app-emulation/wine-any/wine-any-2.10.ebuild
+++ b/app-emulation/wine-any/wine-any-2.10.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -580,7 +580,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -613,5 +613,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.11.ebuild b/app-emulation/wine-any/wine-any-2.11.ebuild
index 2d6272832a64..bb2c5ea4bf1c 100644
--- a/app-emulation/wine-any/wine-any-2.11.ebuild
+++ b/app-emulation/wine-any/wine-any-2.11.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -580,7 +580,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -613,5 +613,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.12.ebuild b/app-emulation/wine-any/wine-any-2.12.ebuild
index 2d6272832a64..bb2c5ea4bf1c 100644
--- a/app-emulation/wine-any/wine-any-2.12.ebuild
+++ b/app-emulation/wine-any/wine-any-2.12.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -580,7 +580,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -613,5 +613,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.13.ebuild b/app-emulation/wine-any/wine-any-2.13.ebuild
index 1be074dd3b6e..76f015333081 100644
--- a/app-emulation/wine-any/wine-any-2.13.ebuild
+++ b/app-emulation/wine-any/wine-any-2.13.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -580,7 +580,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -613,5 +613,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.14.ebuild b/app-emulation/wine-any/wine-any-2.14.ebuild
index 2ad40ace5e16..842b271f5c12 100644
--- a/app-emulation/wine-any/wine-any-2.14.ebuild
+++ b/app-emulation/wine-any/wine-any-2.14.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -580,7 +580,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -613,5 +613,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.15.ebuild b/app-emulation/wine-any/wine-any-2.15.ebuild
index 2ad40ace5e16..842b271f5c12 100644
--- a/app-emulation/wine-any/wine-any-2.15.ebuild
+++ b/app-emulation/wine-any/wine-any-2.15.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -580,7 +580,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -613,5 +613,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.16.ebuild b/app-emulation/wine-any/wine-any-2.16.ebuild
index 2ad40ace5e16..842b271f5c12 100644
--- a/app-emulation/wine-any/wine-any-2.16.ebuild
+++ b/app-emulation/wine-any/wine-any-2.16.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -580,7 +580,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -613,5 +613,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.2.ebuild b/app-emulation/wine-any/wine-any-2.2.ebuild
index c13161d775a5..8562bece7338 100644
--- a/app-emulation/wine-any/wine-any-2.2.ebuild
+++ b/app-emulation/wine-any/wine-any-2.2.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -578,7 +578,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -611,5 +611,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.3.ebuild b/app-emulation/wine-any/wine-any-2.3.ebuild
index c13161d775a5..8562bece7338 100644
--- a/app-emulation/wine-any/wine-any-2.3.ebuild
+++ b/app-emulation/wine-any/wine-any-2.3.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -578,7 +578,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -611,5 +611,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.4.ebuild b/app-emulation/wine-any/wine-any-2.4.ebuild
index edadd8ab3088..f57589e12592 100644
--- a/app-emulation/wine-any/wine-any-2.4.ebuild
+++ b/app-emulation/wine-any/wine-any-2.4.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -578,7 +578,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -611,5 +611,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.5.ebuild b/app-emulation/wine-any/wine-any-2.5.ebuild
index edadd8ab3088..f57589e12592 100644
--- a/app-emulation/wine-any/wine-any-2.5.ebuild
+++ b/app-emulation/wine-any/wine-any-2.5.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -578,7 +578,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -611,5 +611,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.6.ebuild b/app-emulation/wine-any/wine-any-2.6.ebuild
index edadd8ab3088..f57589e12592 100644
--- a/app-emulation/wine-any/wine-any-2.6.ebuild
+++ b/app-emulation/wine-any/wine-any-2.6.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -578,7 +578,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -611,5 +611,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.7.ebuild b/app-emulation/wine-any/wine-any-2.7.ebuild
index edadd8ab3088..f57589e12592 100644
--- a/app-emulation/wine-any/wine-any-2.7.ebuild
+++ b/app-emulation/wine-any/wine-any-2.7.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -578,7 +578,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -611,5 +611,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.8.ebuild b/app-emulation/wine-any/wine-any-2.8.ebuild
index edadd8ab3088..f57589e12592 100644
--- a/app-emulation/wine-any/wine-any-2.8.ebuild
+++ b/app-emulation/wine-any/wine-any-2.8.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -578,7 +578,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -611,5 +611,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-2.9.ebuild b/app-emulation/wine-any/wine-any-2.9.ebuild
index 2d6272832a64..bb2c5ea4bf1c 100644
--- a/app-emulation/wine-any/wine-any-2.9.ebuild
+++ b/app-emulation/wine-any/wine-any-2.9.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -580,7 +580,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -613,5 +613,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}
diff --git a/app-emulation/wine-any/wine-any-9999.ebuild b/app-emulation/wine-any/wine-any-9999.ebuild
index 4be5512a8ff7..323eeca67775 100644
--- a/app-emulation/wine-any/wine-any-9999.ebuild
+++ b/app-emulation/wine-any/wine-any-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eutils xdg-utils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator
+inherit autotools eutils flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx versionator xdg-utils
MY_PN="${PN%%-*}"
MY_P="${MY_PN}-${PV}"
@@ -580,7 +580,7 @@ pkg_postinst() {
eselect wine update --all --if-unset || die
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
if ! use gecko; then
ewarn "Without Wine Gecko, wine prefixes will not have a default"
@@ -613,5 +613,5 @@ pkg_prerm() {
}
pkg_postrm() {
- fdo-xdg_desktop_database_update
+ xdg_desktop_database_update
}