summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-28 07:56:46 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-28 08:13:36 -0400
commit4a9e7bad40eaf1a83fa14d1918971ebd841da786 (patch)
tree3647bfe1ccc972a387b43a1ee404d5af6a3e3509 /app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
parentapp-admin/hcloud: version bump to 1.37.0 (diff)
downloadgentoo-4a9e7bad40eaf1a83fa14d1918971ebd841da786.tar.gz
gentoo-4a9e7bad40eaf1a83fa14d1918971ebd841da786.tar.bz2
gentoo-4a9e7bad40eaf1a83fa14d1918971ebd841da786.zip
app-emulation/wine-vanilla: warn if nvidia[abi_x86_32] is missing
Hard to know for sure if it's really used or not, but do not want to introduce a kinda no-op VIDEO_CARDS on wine to actually depend on it over a warning. Less of an issue with mesa given other dependencies end up requiring it (technically the dep is wrong given e.g. nvidia would not need mesa[abi_x86_32], but well). (not needed with USE="wow64 -abi_x86_32" for 32bit) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
index 1aaebe5aa269..a3fad03a1c4d 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.13.ebuild
@@ -402,6 +402,12 @@ pkg_postinst() {
ewarn "work, be warned that it is not unusual that installers or other helpers"
ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
ewarn "note the experimental/WIP USE=wow64 can allow 32bit without multilib."
+ elif use abi_x86_32 && { use opengl || use vulkan; } &&
+ has_version 'x11-drivers/nvidia-drivers[-abi_x86_32]'
+ then
+ ewarn "x11-drivers/nvidia-drivers is installed but is built without"
+ ewarn "USE=abi_x86_32 (ABI_X86=32), hardware acceleration with 32bit"
+ ewarn "applications under ${PN} will likely not be usable."
fi
eselect wine update --if-unset || die