summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-07-04 19:41:18 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-07-04 19:42:04 +0200
commit83dbb4dd6c6ab25423b5bf69b0043ab710ff6bb3 (patch)
tree3c0dac724be0b35d7481f839b1e473b1e3eb5e82 /app-emulation
parentapp-emulation/free42: add 3.0.13 (diff)
downloadgentoo-83dbb4dd6c6ab25423b5bf69b0043ab710ff6bb3.tar.gz
gentoo-83dbb4dd6c6ab25423b5bf69b0043ab710ff6bb3.tar.bz2
gentoo-83dbb4dd6c6ab25423b5bf69b0043ab710ff6bb3.zip
app-emulation/plus42: add 1.0.9
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/plus42/Manifest1
-rw-r--r--app-emulation/plus42/files/plus42-1.0.9-fix-makefile.patch25
-rw-r--r--app-emulation/plus42/plus42-1.0.9.ebuild50
3 files changed, 76 insertions, 0 deletions
diff --git a/app-emulation/plus42/Manifest b/app-emulation/plus42/Manifest
index f522f663e83d..efe80441b319 100644
--- a/app-emulation/plus42/Manifest
+++ b/app-emulation/plus42/Manifest
@@ -1,2 +1,3 @@
DIST plus42-upstream-1.0.4.tgz 7583399 BLAKE2B 801c125e8b320a2ae2220595aa6244451f55938db644beb5e619c7789b506ada86b4f22e62c724af19da1240aa6c0fad791e2d6176eb4787435f16c1a44aaccc SHA512 a9c23b582047767fe0c57f35fdb4dfb72d7fdf480106a64f1d1151541c5d08e8a1a973156b0e2e5e9ca2f4f74acfbde2a1d69590c02f480d52dec20981be6c6e
DIST plus42-upstream-1.0.6.tgz 7583604 BLAKE2B 3cfdf41ee3ba627cfe5191cf9c0e452917b8511931206fd46df8516a225c7e0e447d8410348d9ab324269a3182dd9c4708ac881f46ae5058fdd4784acec82e2d SHA512 9f4573de916ba20fae4400f50cbf64b9bfbc452b4b51e4c674cffd5129cac9c9828eee33ab613abed6d94c5863797c17e3bd78b0df50bbaa8e0f9594450713ab
+DIST plus42-upstream-1.0.9.tgz 7585218 BLAKE2B e6c09c985fcf3f037a0c1dc1f4f445ef18c4f73962ffbf46939b91d5a96c9f079bd36b328b30fcae42f0bc13ebee7a1f56e51762f225f41fb715ab88e8b93d56 SHA512 77c06cf33d375f513c6806910f6b8bdda865853e7890922174364a7d2a07e35a6bbae2e62800c7658be01fe8b3aafbfc7f53a19451475b411865fe69bef090d8
diff --git a/app-emulation/plus42/files/plus42-1.0.9-fix-makefile.patch b/app-emulation/plus42/files/plus42-1.0.9-fix-makefile.patch
new file mode 100644
index 000000000000..b66c15b89b5a
--- /dev/null
+++ b/app-emulation/plus42/files/plus42-1.0.9-fix-makefile.patch
@@ -0,0 +1,25 @@
+diff -Naur plus42-upstream-1.0.9.orig/gtk/Makefile plus42-upstream-1.0.9/gtk/Makefile
+--- plus42-upstream-1.0.9.orig/gtk/Makefile 2022-06-19 14:44:32.000000000 +0200
++++ plus42-upstream-1.0.9/gtk/Makefile 2022-07-04 19:37:35.533799322 +0200
+@@ -40,9 +40,10 @@
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1
+
+-CXXFLAGS = $(CFLAGS) \
++CXXFLAGS := $(CFLAGS) \
+ -fno-rtti \
+- -D_WCHAR_T_DEFINED
++ -D_WCHAR_T_DEFINED \
++ ${CXXFLAGS}
+
+ LIBS = gcc111libbid.a $(shell $(PKG_CONFIG) --libs gtk+-3.0)
+
+@@ -121,7 +122,7 @@
+ ./keymap2cc
+
+ gcc111libbid.a:
+- sh ./build-intel-lib.sh
++ +sh ./build-intel-lib.sh
+ ln -s IntelRDFPMathLib20U1/TESTS/readtest.c
+
+ symlinks:
diff --git a/app-emulation/plus42/plus42-1.0.9.ebuild b/app-emulation/plus42/plus42-1.0.9.ebuild
new file mode 100644
index 000000000000..b73a2da34bf8
--- /dev/null
+++ b/app-emulation/plus42/plus42-1.0.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PV="${PN}-upstream-${PV}"
+
+DESCRIPTION="An Enhanced HP-42S Calculator Simulator"
+HOMEPAGE="https://thomasokken.com/plus42/"
+SRC_URI="https://thomasokken.com/plus42/upstream/${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa"
+
+DEPEND="dev-libs/atk
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( CREDITS HISTORY README )
+S="${WORKDIR}/${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.9-fix-makefile.patch"
+ "${FILESDIR}/${PN}-1.0.4-fix-build-intel-lib.patch"
+)
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
+ emake -C gtk clean
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
+}
+
+src_install() {
+ default
+ dobin gtk/plus42bin gtk/plus42dec
+}