summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-06-28 08:11:29 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-06-28 11:08:59 +0200
commitc8f09be0bec15256df87a888c50e53531fdafcca (patch)
tree7d2556eb9ba248cc3056f73930015e88859ded4f /app-eselect/eselect-gradle/eselect-gradle-0.2-r1.ebuild
parentmetadata/install-qa-check.d: add "QA Notice:" string to some checks (diff)
downloadgentoo-c8f09be0bec15256df87a888c50e53531fdafcca.tar.gz
gentoo-c8f09be0bec15256df87a888c50e53531fdafcca.tar.bz2
gentoo-c8f09be0bec15256df87a888c50e53531fdafcca.zip
app-eselect/eselect-gradle: fix RDEPEND
I was somehow under the impression that gradle-bin-6.3 from ::gentoo also installs /usr/bin/gradle, just as eselect-gradle. But this turned out to be not the case. So we can drop the dependency constraint from RDEPEND and resolve the circular dependency. Closes: https://bugs.gentoo.org/798885 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-gradle/eselect-gradle-0.2-r1.ebuild')
-rw-r--r--app-eselect/eselect-gradle/eselect-gradle-0.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-eselect/eselect-gradle/eselect-gradle-0.2-r1.ebuild b/app-eselect/eselect-gradle/eselect-gradle-0.2-r1.ebuild
new file mode 100644
index 000000000000..4277ecbfd31a
--- /dev/null
+++ b/app-eselect/eselect-gradle/eselect-gradle-0.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manage multiple Gradle versions on one system"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/Flow/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/Flow/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins gradle.eselect
+}