summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-30 20:07:16 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-30 20:13:41 +0200
commit5a259c088a0ab975497449e177dc8e725451d4e7 (patch)
treeec021d728740df06a4f00b51f2fd465035b91bb8 /app-eselect/eselect-repository/eselect-repository-5.ebuild
parentRevert "dev-libs/botan: fix EAPI=7 ED reference" (diff)
downloadgentoo-5a259c088a0ab975497449e177dc8e725451d4e7.tar.gz
gentoo-5a259c088a0ab975497449e177dc8e725451d4e7.tar.bz2
gentoo-5a259c088a0ab975497449e177dc8e725451d4e7.zip
app-eselect/eselect-repository: Bump to v5
v5 fixes listing local repositories. Closes: https://bugs.gentoo.org/666368 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-repository/eselect-repository-5.ebuild')
-rw-r--r--app-eselect/eselect-repository/eselect-repository-5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-eselect/eselect-repository/eselect-repository-5.ebuild b/app-eselect/eselect-repository/eselect-repository-5.ebuild
new file mode 100644
index 000000000000..06ccc47c631d
--- /dev/null
+++ b/app-eselect/eselect-repository/eselect-repository-5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
+inherit python-single-r1
+
+DESCRIPTION="Manage repos.conf via eselect"
+HOMEPAGE="https://github.com/mgorny/eselect-repository"
+SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ app-admin/eselect
+ dev-python/lxml[${PYTHON_USEDEP}]
+ net-misc/wget"
+
+src_compile() {
+ MAKEARGS=(
+ PREFIX="${EPREFIX}/usr"
+ SYSCONFDIR="${EPREFIX}/etc"
+ SHAREDSTATEDIR="${EPREFIX}/var"
+ ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
+ )
+
+ emake "${MAKEARGS[@]}"
+ python_fix_shebang eselect-repo-helper
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ keepdir /var/db/repos
+ einstalldocs
+}