summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-09-03 22:45:17 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-09-03 22:45:17 +0900
commit770f20695fc22c639cb84d0a046bc83793da62d6 (patch)
tree2cb178ce0b965e28839373521d311a02dcdb641d /app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.3.ebuild
parentapp-i18n/ibus-table-chinese: update to EAPI 7 (diff)
downloadgentoo-770f20695fc22c639cb84d0a046bc83793da62d6.tar.gz
gentoo-770f20695fc22c639cb84d0a046bc83793da62d6.tar.bz2
gentoo-770f20695fc22c639cb84d0a046bc83793da62d6.zip
app-i18n/ibus-table-chinese: new upstream release
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.3.ebuild')
-rw-r--r--app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.3.ebuild b/app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.3.ebuild
new file mode 100644
index 000000000000..a34f0e609639
--- /dev/null
+++ b/app-i18n/ibus-table-chinese/ibus-table-chinese-1.8.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+CMAKE_IN_SOURCE_BUILD="1"
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+inherit cmake
+
+DESCRIPTION="Chinese tables for IBus-Table"
+HOMEPAGE="https://github.com/definite/ibus-table-chinese"
+SRC_URI="https://github.com/definite/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-i18n/ibus-table"
+DEPEND="${RDEPEND}
+ dev-util/cmake-fedora"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_FEDORA_TMP_DIR="${T}"
+ -DDATA_DIR="${EPREFIX}"/usr/share
+ -DMANAGE_DEPENDENCY_PACKAGE_EXISTS_CMD=false
+ -DPRJ_DOC_DIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+ cmake_src_configure
+}