summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-09 15:40:49 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-09 15:54:08 +0900
commit771f8de19325888189058789205c48d008a87d84 (patch)
tree4d4ec26ccb66bd1a41a93fa6c655e9e45b3903c5 /app-i18n/libkkc
parentapp-xemacs/gnats: drop 1.17 (diff)
downloadgentoo-771f8de19325888189058789205c48d008a87d84.tar.gz
gentoo-771f8de19325888189058789205c48d008a87d84.tar.bz2
gentoo-771f8de19325888189058789205c48d008a87d84.zip
app-i18n/libkkc: tidy
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/libkkc')
-rw-r--r--app-i18n/libkkc/libkkc-0.3.6_pre20190809104047.ebuild26
-rw-r--r--app-i18n/libkkc/libkkc-9999.ebuild26
2 files changed, 24 insertions, 28 deletions
diff --git a/app-i18n/libkkc/libkkc-0.3.6_pre20190809104047.ebuild b/app-i18n/libkkc/libkkc-0.3.6_pre20190809104047.ebuild
index d563af26c2cd..16e4031c08f2 100644
--- a/app-i18n/libkkc/libkkc-0.3.6_pre20190809104047.ebuild
+++ b/app-i18n/libkkc/libkkc-0.3.6_pre20190809104047.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2013-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python{3_7,3_8,3_9})
+PYTHON_COMPAT=( python3_{7..9} )
inherit autotools python-any-r1 vala
@@ -11,7 +11,9 @@ if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/ueno/libkkc"
elif [[ "${PV}" == *_pre* ]]; then
- LIBKKC_GIT_REVISION="b2e5a152980ee627c39ca8a49082e6df7694b8fc"
+ inherit vcs-snapshot
+
+ EGIT_COMMIT="b2e5a152980ee627c39ca8a49082e6df7694b8fc"
fi
DESCRIPTION="Japanese Kana Kanji conversion input method library"
@@ -19,7 +21,7 @@ HOMEPAGE="https://github.com/ueno/libkkc"
if [[ "${PV}" == "9999" ]]; then
SRC_URI=""
elif [[ "${PV}" == *_pre* ]]; then
- SRC_URI="https://github.com/ueno/${PN}/archive/${LIBKKC_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/ueno/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
else
SRC_URI="https://github.com/ueno/${PN}/releases/download/v${PV}/${P}.tar.gz"
fi
@@ -29,21 +31,17 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls static-libs"
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ dev-libs/marisa
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
BDEPEND="$(python_gen_any_dep 'dev-libs/marisa[python,${PYTHON_USEDEP}]')
$(vala_depend)
dev-libs/gobject-introspection
virtual/pkgconfig
nls? ( sys-devel/gettext )"
-DEPEND="dev-libs/glib:2
- dev-libs/json-glib
- dev-libs/libgee:0.8
- dev-libs/marisa
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
-
-if [[ "${PV}" == *_pre* ]]; then
- S="${WORKDIR}/libkkc-${LIBKKC_GIT_REVISION}"
-fi
python_check_deps() {
has_version -b "dev-libs/marisa[python,${PYTHON_USEDEP}]"
diff --git a/app-i18n/libkkc/libkkc-9999.ebuild b/app-i18n/libkkc/libkkc-9999.ebuild
index 1743990197eb..cd65127fb1ea 100644
--- a/app-i18n/libkkc/libkkc-9999.ebuild
+++ b/app-i18n/libkkc/libkkc-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2013-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python{3_7,3_8,3_9})
+PYTHON_COMPAT=( python3_{7..9} )
inherit autotools python-any-r1 vala
@@ -11,7 +11,9 @@ if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/ueno/libkkc"
elif [[ "${PV}" == *_pre* ]]; then
- LIBKKC_GIT_REVISION=""
+ inherit vcs-snapshot
+
+ EGIT_COMMIT=""
fi
DESCRIPTION="Japanese Kana Kanji conversion input method library"
@@ -19,7 +21,7 @@ HOMEPAGE="https://github.com/ueno/libkkc"
if [[ "${PV}" == "9999" ]]; then
SRC_URI=""
elif [[ "${PV}" == *_pre* ]]; then
- SRC_URI="https://github.com/ueno/${PN}/archive/${LIBKKC_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/ueno/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
else
SRC_URI="https://github.com/ueno/${PN}/releases/download/v${PV}/${P}.tar.gz"
fi
@@ -29,21 +31,17 @@ SLOT="0"
KEYWORDS=""
IUSE="nls static-libs"
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ dev-libs/libgee:0.8
+ dev-libs/marisa
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
BDEPEND="$(python_gen_any_dep 'dev-libs/marisa[python,${PYTHON_USEDEP}]')
$(vala_depend)
dev-libs/gobject-introspection
virtual/pkgconfig
nls? ( sys-devel/gettext )"
-DEPEND="dev-libs/glib:2
- dev-libs/json-glib
- dev-libs/libgee:0.8
- dev-libs/marisa
- nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
-
-if [[ "${PV}" == *_pre* ]]; then
- S="${WORKDIR}/libkkc-${LIBKKC_GIT_REVISION}"
-fi
python_check_deps() {
has_version -b "dev-libs/marisa[python,${PYTHON_USEDEP}]"