summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/pology/pology-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/pology/pology-9999.ebuild')
-rw-r--r--app-i18n/pology/pology-9999.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-i18n/pology/pology-9999.ebuild b/app-i18n/pology/pology-9999.ebuild
new file mode 100644
index 000000000000..f78ef42b91ee
--- /dev/null
+++ b/app-i18n/pology/pology-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ESVN_REPO_URI="svn://anonsvn.kde.org/home/kde/trunk/l10n-support/pology"
+PYTHON_COMPAT=( python2_7 )
+
+[[ ${PV} == 9999 ]] && VCS_ECLASS="subversion"
+
+inherit python-single-r1 cmake-utils bash-completion-r1 ${VCS_ECLASS}
+unset VCS_ECLASS
+
+DESCRIPTION="A framework for custom processing of PO files"
+HOMEPAGE="http://pology.nedohodnik.net"
+[[ ${PV} == 9999 ]] || SRC_URI="http://pology.nedohodnik.net//release/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libxslt
+ dev-libs/libxml2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-python/epydoc[${PYTHON_USEDEP}]
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Magic on python parsing makes it impossible to make it parallel safe
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ python_fix_shebang .
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dosym ../../../pology/syntax/kate/synder.xml /usr/share/apps/katepart/syntax/synder.xml
+
+ newbashcomp "${ED}"/usr/share/pology/completion/bash/pology posieve
+ bashcomp_alias {posieve,poediff}{,.py}
+
+ einfo "You should also consider following packages to install:"
+ einfo " app-text/aspell"
+ einfo " app-text/hunspell"
+ einfo " dev-vcs/git"
+ einfo " dev-vcs/subversion"
+ einfo " sci-misc/apertium"
+}