summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-07 21:48:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-08 01:05:56 +0200
commit1407a9a57a4003570da3f99ab8fd5e67454967d7 (patch)
treec018ffca2676ae1a6081a8d78fe038e558e75181 /app-i18n
parentkde-plasma/plasma-workspace: Fix plasma-browser-integration-host crashes (diff)
downloadgentoo-1407a9a57a4003570da3f99ab8fd5e67454967d7.tar.gz
gentoo-1407a9a57a4003570da3f99ab8fd5e67454967d7.tar.bz2
gentoo-1407a9a57a4003570da3f99ab8fd5e67454967d7.zip
app-i18n/fcitx-configtool: Drop IUSE qt6
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-5.1.6-r2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-5.1.6-r2.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-5.1.6-r2.ebuild
new file mode 100644
index 000000000000..ce5113443197
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-5.1.6-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-configtool"
+
+inherit cmake unpacker
+
+DESCRIPTION="Configuration module for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-configtool"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.zst -> ${P}.tar.zst"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="amd64"
+IUSE="kcm +config-qt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.6:5
+ >=app-i18n/fcitx-qt-5.1.4:5[qt6(+),-onlyplugin]
+ app-text/iso-codes
+ dev-qt/qtbase:6[concurrent,dbus,gui,widgets]
+ dev-qt/qtsvg:6
+ kde-frameworks/kwidgetsaddons:6
+ sys-devel/gettext
+ virtual/libintl
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ config-qt? ( kde-frameworks/kitemviews:6 )
+ kcm? (
+ dev-qt/qtdeclarative:6
+ kde-frameworks/kcoreaddons:6
+ kde-frameworks/kdeclarative:6
+ kde-frameworks/ki18n:6
+ kde-frameworks/kiconthemes:6
+ kde-frameworks/kirigami:6
+ kde-frameworks/kpackage:6
+ kde-frameworks/ksvg:6
+ kde-frameworks/kcmutils:6
+ kde-plasma/libplasma:6
+ x11-libs/libxkbcommon
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(unpacker_src_uri_depends)
+ kde-frameworks/extra-cmake-modules:0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=yes
+ -DENABLE_KCM=$(usex kcm)
+ -DENABLE_CONFIG_QT=$(usex config-qt)
+ -DENABLE_TEST=$(usex test)
+ -DUSE_QT6=ON
+ )
+
+ cmake_src_configure
+}