summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-leechcraft/lc-core/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-leechcraft/lc-core/files')
-rw-r--r--app-leechcraft/lc-core/files/lc-core-0.6.65-dbus-optional.patch87
-rw-r--r--app-leechcraft/lc-core/files/lc-core-0.6.65-gcc-4.9.patch48
2 files changed, 135 insertions, 0 deletions
diff --git a/app-leechcraft/lc-core/files/lc-core-0.6.65-dbus-optional.patch b/app-leechcraft/lc-core/files/lc-core-0.6.65-dbus-optional.patch
new file mode 100644
index 000000000000..6d784608b3bc
--- /dev/null
+++ b/app-leechcraft/lc-core/files/lc-core-0.6.65-dbus-optional.patch
@@ -0,0 +1,87 @@
+commit 2e221a116dacf7541af8bfe6110856a70b8a8f70
+Author: 0xd34df00d <0xd34df00d@gmail.com>
+Date: Mon Jun 16 14:54:15 2014 +0400
+
+ [Core] DBus loaders made optional.
+
+diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
+index c138fd5..dc2b8d6 100644
+--- a/src/core/CMakeLists.txt
++++ b/src/core/CMakeLists.txt
+@@ -5,8 +5,10 @@ include_directories (${CMAKE_CURRENT_BINARY_DIR}
+ ${Boost_INCLUDE_DIR}
+ )
+
++option (WITH_DBUS_LOADERS "Build D-Bus loaders on UNIX" OFF)
++
+ if (NOT USE_QT5)
+- if (NOT WIN32)
++ if (WITH_DBUS_LOADERS)
+ set (QT_USE_QTDBUS TRUE)
+ endif ()
+ set (QT_USE_QTNETWORK TRUE)
+@@ -101,7 +103,7 @@ set (SRCS
+ loaders/sopluginloader.cpp
+ )
+
+-if (UNIX AND NOT APPLE)
++if (WITH_DBUS_LOADERS)
+ set (SRCS
+ ${SRCS}
+ loaders/dbuspluginloader.cpp
+@@ -179,6 +181,6 @@ if (USE_QT5)
+ QT5_USE_MODULES (leechcraft Gui Network Widgets Xml Sql Script Concurrent DBus Svg)
+ endif ()
+
+-if (UNIX AND NOT APPLE)
++if (WITH_DBUS_LOADERS)
+ add_subdirectory (loaders/dbus)
+ endif ()
+commit 4017753193a769a8bf7de6a54ec2c66954401e2f
+Author: 0xd34df00d <0xd34df00d@gmail.com>
+Date: Mon Jun 16 17:15:57 2014 +0400
+
+ [Core] Fixed linking without WITH_DBUS_LOADERS.
+
+diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
+index dc2b8d6..5f593ea 100644
+--- a/src/core/CMakeLists.txt
++++ b/src/core/CMakeLists.txt
+@@ -7,6 +7,10 @@ include_directories (${CMAKE_CURRENT_BINARY_DIR}
+
+ option (WITH_DBUS_LOADERS "Build D-Bus loaders on UNIX" OFF)
+
++if (WITH_DBUS_LOADERS)
++ add_definitions (-DWITH_DBUS_LOADERS)
++endif ()
++
+ if (NOT USE_QT5)
+ if (WITH_DBUS_LOADERS)
+ set (QT_USE_QTDBUS TRUE)
+diff --git a/src/core/pluginmanager.cpp b/src/core/pluginmanager.cpp
+index e769715..4cb479a 100644
+--- a/src/core/pluginmanager.cpp
++++ b/src/core/pluginmanager.cpp
+@@ -56,9 +56,11 @@
+ #include "shortcutmanager.h"
+ #include "application.h"
+ #include "loaders/sopluginloader.h"
+-#ifdef Q_OS_LINUX
+- #include "loaders/dbuspluginloader.h"
++
++#ifdef WITH_DBUS_LOADERS
++#include "loaders/dbuspluginloader.h"
+ #endif
++
+ #include "settingstab.h"
+
+ namespace LeechCraft
+@@ -985,7 +987,7 @@ namespace LeechCraft
+
+ Loaders::IPluginLoader_ptr PluginManager::MakeLoader (const QString& filename)
+ {
+-#ifndef Q_OS_LINUX
++#ifndef WITH_DBUS_LOADERS
+ return Loaders::IPluginLoader_ptr (new Loaders::SOPluginLoader (filename));
+ #else
+ if (DBusMode_)
diff --git a/app-leechcraft/lc-core/files/lc-core-0.6.65-gcc-4.9.patch b/app-leechcraft/lc-core/files/lc-core-0.6.65-gcc-4.9.patch
new file mode 100644
index 000000000000..1ea3cc410c67
--- /dev/null
+++ b/app-leechcraft/lc-core/files/lc-core-0.6.65-gcc-4.9.patch
@@ -0,0 +1,48 @@
+From 2db7cf510491e3ef2f25341b35b3705acf824bc3 Mon Sep 17 00:00:00 2001
+From: 0xd34df00d <0xd34df00d@gmail.com>
+Date: Thu, 12 Jun 2014 23:38:39 +0400
+Subject: [PATCH] [Interfaces] Added missing include.
+
+---
+ src/interfaces/itexteditor.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/interfaces/itexteditor.h b/src/interfaces/itexteditor.h
+index 059b936..0004bc5 100644
+--- a/src/interfaces/itexteditor.h
++++ b/src/interfaces/itexteditor.h
+@@ -29,6 +29,7 @@
+
+ #pragma once
+
++#include <functional>
+ #include <QPair>
+ #include <QList>
+ #include <QRegExp>
+--
+1.9.3
+
+From 317cbe27a95cc6536f163c0c833eeb1b4fb3f53b Mon Sep 17 00:00:00 2001
+From: 0xd34df00d <0xd34df00d@gmail.com>
+Date: Thu, 12 Jun 2014 23:32:15 +0400
+Subject: [PATCH] [Util] Added a missing include.
+
+---
+ src/util/qml/plotitem.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/util/qml/plotitem.h b/src/util/qml/plotitem.h
+index 194c69c..8185851 100644
+--- a/src/util/qml/plotitem.h
++++ b/src/util/qml/plotitem.h
+@@ -29,6 +29,7 @@
+
+ #pragma once
+
++#include <functional>
+ #include <QDeclarativeItem>
+ #include "qmlconfig.h"
+
+--
+1.9.3
+