summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/cmatrix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/cmatrix')
-rw-r--r--app-misc/cmatrix/Manifest1
-rw-r--r--app-misc/cmatrix/cmatrix-1.2a-r1.ebuild47
-rw-r--r--app-misc/cmatrix/files/cmatrix-1.2a-fontdir.patch28
-rw-r--r--app-misc/cmatrix/files/cmatrix-1.2a-gentoo.patch48
-rw-r--r--app-misc/cmatrix/metadata.xml7
5 files changed, 131 insertions, 0 deletions
diff --git a/app-misc/cmatrix/Manifest b/app-misc/cmatrix/Manifest
new file mode 100644
index 000000000000..e2dc0fef8ef1
--- /dev/null
+++ b/app-misc/cmatrix/Manifest
@@ -0,0 +1 @@
+DIST cmatrix-1.2a.tar.gz 74376 SHA256 1fa6e6caea254b6fe70a492efddc1b40ad7ccb950a5adfd80df75b640577064c SHA512 a653a840378da87877bda1b48fc4087e7789b548e0f943ae15b81b5dc7a847aed28c69d2ad955bd467f38d6a08b0960349490b61c30260767e7d1560bb542d82 WHIRLPOOL 35df82e9aa1c52d59ec89130b275f02457e80750c705c372469a0d3f69484ab853b6ee416126a1130c3450dab580f5ee2aef2091a1ece5af4b352e115ee576f3
diff --git a/app-misc/cmatrix/cmatrix-1.2a-r1.ebuild b/app-misc/cmatrix/cmatrix-1.2a-r1.ebuild
new file mode 100644
index 000000000000..9d107b569e8a
--- /dev/null
+++ b/app-misc/cmatrix/cmatrix-1.2a-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils
+
+DESCRIPTION="An ncurses based app to show a scrolling screen from the Matrix"
+HOMEPAGE="http://www.asty.org/cmatrix"
+SRC_URI="http://www.asty.org/${PN}/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ~ppc64 sparc x86"
+IUSE="X"
+
+DEPEND="X? ( x11-apps/mkfontdir )
+ sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ # patch Makefile.am to make sure the fonts installations don't violate the
+ # sandbox.
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ if use X ; then
+ epatch "${FILESDIR}"/${P}-fontdir.patch
+ fi
+ eautoreconf
+}
+
+src_install() {
+ dodir /usr/share/consolefonts || die 'dodir failed'
+ dodir /usr/lib/kbd/consolefonts || die 'dodir failed'
+ if use X;then
+ dodir /usr/share/fonts/misc || die 'dodir failed'
+ fi
+ emake DESTDIR="${D}" install || die 'emake install failed'
+}
+
+pkg_postinst() {
+ if use X; then
+ if [ -d "${ROOT}"usr/share/fonts/misc ] ; then
+ einfo ">>> Running mkfontdir on ${ROOT}usr/share/fonts/misc"
+ mkfontdir "${ROOT}"usr/share/fonts/misc || die 'mkfontdir failed'
+ fi
+ fi
+}
diff --git a/app-misc/cmatrix/files/cmatrix-1.2a-fontdir.patch b/app-misc/cmatrix/files/cmatrix-1.2a-fontdir.patch
new file mode 100644
index 000000000000..6e69841b5e01
--- /dev/null
+++ b/app-misc/cmatrix/files/cmatrix-1.2a-fontdir.patch
@@ -0,0 +1,28 @@
+diff -Naru cmatrix-1.2a.orig/Makefile.am cmatrix-1.2a/Makefile.am
+--- cmatrix-1.2a.orig/Makefile.am 2008-12-24 02:37:43.000000000 +0000
++++ cmatrix-1.2a/Makefile.am 2008-12-24 02:50:08.000000000 +0000
+@@ -18,20 +18,9 @@
+ $(INSTALL_DATA) $(srcdir)/matrix.fnt $(DESTDIR)/usr/lib/kbd/consolefonts; \
+ $(INSTALL_DATA) $(srcdir)/matrix.psf.gz $(DESTDIR)/usr/lib/kbd/consolefonts; \
+ fi
+- @if test -d /usr/lib/X11/fonts/misc; then \
+- echo " Installing X window matrix fonts in $(DESTDIR)/usr/lib/X11/fonts/misc..."; \
+- $(INSTALL_DATA) $(srcdir)/mtx.pcf $(DESTDIR)/usr/lib/X11/fonts/misc; \
+- $(INSTALL_DATA) $(srcdir)/mtx.pcf $(DESTDIR)/usr/lib/X11/fonts/misc; \
+- echo " Running mkfontdir $(DESTDIR)/usr/lib/X11/fonts/misc..."; \
+- echo " Done. If this is the first time you have installed CMatrix you will"; \
++ @if test -d /usr/share/fonts/misc; then \
++ echo " Installing X window matrix fonts in $(DESTDIR)/usr/share/fonts/misc..."; \
++ $(INSTALL_DATA) $(srcdir)/mtx.pcf $(DESTDIR)/usr/share/fonts/misc; \
++ echo " If this is the first time you have installed CMatrix you will"; \
+ echo " probably have to restart X window in order to use the mtx.pcf font."; \
+- else \
+- if test -d /usr/X11R6/lib/X11/fonts/misc; then \
+- echo " Installing X window matrix fonts in $(DESTDIR)/usr/X11R6/lib/X11/fonts/misc..."; \
+- $(INSTALL_DATA) $(srcdir)/mtx.pcf $(DESTDIR)/usr/X11R6/lib/X11/fonts/misc; \
+- $(INSTALL_DATA) $(srcdir)/mtx.pcf $(DESTDIR)/usr/X11R6/lib/X11/fonts/misc; \
+- echo " Running mkfontdir $(DESTDIR)/usr/X11R6/lib/X11/fonts/misc..."; \
+- echo " Done. If this is the first time you have installed CMatrix you will"; \
+- echo " probably have to restart X window in order to use the mtx.pcf font."; \
+- fi \
+ fi
diff --git a/app-misc/cmatrix/files/cmatrix-1.2a-gentoo.patch b/app-misc/cmatrix/files/cmatrix-1.2a-gentoo.patch
new file mode 100644
index 000000000000..5f88cd0fa876
--- /dev/null
+++ b/app-misc/cmatrix/files/cmatrix-1.2a-gentoo.patch
@@ -0,0 +1,48 @@
+diff -urN cmatrix-1.2a.old/Makefile.am cmatrix-1.2a/Makefile.am
+--- cmatrix-1.2a.old/Makefile.am Sun Mar 31 17:17:17 2002
++++ cmatrix-1.2a/Makefile.am Sat Jul 6 05:32:06 2002
+@@ -9,30 +9,28 @@
+
+ install-data-local:
+ @if test -d /usr/share/consolefonts; then \
+- echo " Installing matrix fonts in /usr/share/consolefonts..."; \
+- $(INSTALL_DATA) $(srcdir)/matrix.fnt /usr/share/consolefonts; \
+- $(INSTALL_DATA) $(srcdir)/matrix.psf.gz /usr/share/consolefonts; \
++ echo " Installing matrix fonts in $(DESTDIR)/usr/share/consolefonts..."; \
++ $(INSTALL_DATA) $(srcdir)/matrix.fnt $(DESTDIR)/usr/share/consolefonts; \
++ $(INSTALL_DATA) $(srcdir)/matrix.psf.gz $(DESTDIR)/usr/share/consolefonts; \
+ fi
+ @if test -d /usr/lib/kbd/consolefonts; then \
+- echo " Installing matrix fonts in /usr/lib/kbd/consolefonts..."; \
+- $(INSTALL_DATA) $(srcdir)/matrix.fnt /usr/lib/kbd/consolefonts; \
+- $(INSTALL_DATA) $(srcdir)/matrix.psf.gz /usr/lib/kbd/consolefonts; \
++ echo " Installing matrix fonts in $(DESTDIR)/usr/lib/kbd/consolefonts..."; \
++ $(INSTALL_DATA) $(srcdir)/matrix.fnt $(DESTDIR)/usr/lib/kbd/consolefonts; \
++ $(INSTALL_DATA) $(srcdir)/matrix.psf.gz $(DESTDIR)/usr/lib/kbd/consolefonts; \
+ fi
+ @if test -d /usr/lib/X11/fonts/misc; then \
+- echo " Installing X window matrix fonts in /usr/lib/X11/fonts/misc..."; \
+- $(INSTALL_DATA) $(srcdir)/mtx.pcf /usr/lib/X11/fonts/misc; \
+- $(INSTALL_DATA) $(srcdir)/mtx.pcf /usr/lib/X11/fonts/misc; \
+- echo " Running mkfontdir /usr/lib/X11/fonts/misc..."; \
+- $(MKFONTDIR) /usr/lib/X11/fonts/misc; \
++ echo " Installing X window matrix fonts in $(DESTDIR)/usr/lib/X11/fonts/misc..."; \
++ $(INSTALL_DATA) $(srcdir)/mtx.pcf $(DESTDIR)/usr/lib/X11/fonts/misc; \
++ $(INSTALL_DATA) $(srcdir)/mtx.pcf $(DESTDIR)/usr/lib/X11/fonts/misc; \
++ echo " Running mkfontdir $(DESTDIR)/usr/lib/X11/fonts/misc..."; \
+ echo " Done. If this is the first time you have installed CMatrix you will"; \
+ echo " probably have to restart X window in order to use the mtx.pcf font."; \
+ else \
+ if test -d /usr/X11R6/lib/X11/fonts/misc; then \
+- echo " Installing X window matrix fonts in /usr/X11R6/lib/X11/fonts/misc..."; \
+- $(INSTALL_DATA) $(srcdir)/mtx.pcf /usr/X11R6/lib/X11/fonts/misc; \
+- $(INSTALL_DATA) $(srcdir)/mtx.pcf /usr/X11R6/lib/X11/fonts/misc; \
+- echo " Running mkfontdir /usr/X11R6/lib/X11/fonts/misc..."; \
+- $(MKFONTDIR) /usr/X11R6/lib/X11/fonts/misc; \
++ echo " Installing X window matrix fonts in $(DESTDIR)/usr/X11R6/lib/X11/fonts/misc..."; \
++ $(INSTALL_DATA) $(srcdir)/mtx.pcf $(DESTDIR)/usr/X11R6/lib/X11/fonts/misc; \
++ $(INSTALL_DATA) $(srcdir)/mtx.pcf $(DESTDIR)/usr/X11R6/lib/X11/fonts/misc; \
++ echo " Running mkfontdir $(DESTDIR)/usr/X11R6/lib/X11/fonts/misc..."; \
+ echo " Done. If this is the first time you have installed CMatrix you will"; \
+ echo " probably have to restart X window in order to use the mtx.pcf font."; \
+ fi \
diff --git a/app-misc/cmatrix/metadata.xml b/app-misc/cmatrix/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/app-misc/cmatrix/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>