summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2020-03-18 22:42:19 +0100
committerTupone Alfredo <tupone@gentoo.org>2020-03-18 22:42:19 +0100
commit5334217bfb43ffd43091736e1f144e629c0cfbd1 (patch)
tree078401f0b87f3942f8a5403ccffabc65d8ca76aa /app-misc/geneweb/geneweb-6.08-r2.ebuild
parentdev-java/openjfx: append -Wno-error (diff)
downloadgentoo-5334217bfb43ffd43091736e1f144e629c0cfbd1.tar.gz
gentoo-5334217bfb43ffd43091736e1f144e629c0cfbd1.tar.bz2
gentoo-5334217bfb43ffd43091736e1f144e629c0cfbd1.zip
app-misc/geneweb: Remove old versions
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'app-misc/geneweb/geneweb-6.08-r2.ebuild')
-rw-r--r--app-misc/geneweb/geneweb-6.08-r2.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/app-misc/geneweb/geneweb-6.08-r2.ebuild b/app-misc/geneweb/geneweb-6.08-r2.ebuild
deleted file mode 100644
index a962e673485d..000000000000
--- a/app-misc/geneweb/geneweb-6.08-r2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit eutils
-
-DESCRIPTION="Genealogy software program with a Web interface"
-HOMEPAGE="https://github.com/geneanet/geneweb"
-SRC_URI="https://github.com/geneweb/geneweb/archive/v6.08.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~tupone/${P}-ocaml-4.patch.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt"
-RESTRICT="strip"
-
-RDEPEND="dev-lang/ocaml[ocamlopt?]
- dev-ml/camlp5[ocamlopt?]
- acct-user/geneweb
- acct-group/geneweb"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${WORKDIR}"/${P}-ocaml-4.patch
- "${FILESDIR}"/${P}-r1-gentoo.patch
- "${FILESDIR}"/${P}-parallellbuild.patch )
-
-src_compile() {
- if use ocamlopt; then
- emake
- else
- emake OCAMLC=ocamlc OCAMLOPT=ocamlopt out
- # If using bytecode we dont want to strip the binary as it would remove
- # the bytecode and only leave ocamlrun...
- fi
-}
-
-src_install() {
- dodoc ICHANGES
- emake new_distrib
- emake wrappers
- # Install doc
- cd distribution
- dodoc CHANGES.txt
- # Install binaries
- cd gw
- dobin gwc gwc1 gwc2 consang gwd gwu update_nldb ged2gwb ged2gwb2 gwb2ged gwsetup
- insinto /usr/lib/${PN}
- doins -r gwtp_tmp/*
- dodoc a.gwf
- insinto /usr/share/${PN}
- doins -r etc images lang setup gwd.arg only.txt
-
- cd ../..
-
- # Install binaries
- dobin src/check_base
- # Install manpages
- doman man/*
-
- # Install doc
- dodoc -r contrib
- docompress -x /usr/share/doc/${PF}/contrib
-
- newinitd "${FILESDIR}/geneweb.initd" geneweb
- newconfd "${FILESDIR}/geneweb.confd" geneweb
-}
-
-pkg_postinst() {
- einfo "A CGI program has been installed in /usr/lib/${PN}. Follow the"
- einfo "instructions on the README in that directory to use it"
- einfo "For 64 bits architecture you need to rebuild the database"
- einfo "\"gwu foo > foo.gw \" will save the database (use the previous"
- einfo "version to do that). \"gwc2 foo.gw -o bar \" will restore it "
- einfo "(using the current package)"
-}