summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-09-13 12:59:20 +0200
committerAmy Liffey <amynka@gentoo.org>2017-09-13 18:55:49 +0200
commit7a8317434887850fa33561c213ae5dc7daee0594 (patch)
tree78d591a436fc37939aa696abec9df4edf3c4ffb5 /app-misc/joy2key
parentsys-kernel/gentoo-sources: Validate the output buffer length for L2CAP config... (diff)
downloadgentoo-7a8317434887850fa33561c213ae5dc7daee0594.tar.gz
gentoo-7a8317434887850fa33561c213ae5dc7daee0594.tar.bz2
gentoo-7a8317434887850fa33561c213ae5dc7daee0594.zip
app-misc/joy2key: EAPI 6 bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-misc/joy2key')
-rw-r--r--app-misc/joy2key/joy2key-1.6.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/joy2key/joy2key-1.6.3-r1.ebuild b/app-misc/joy2key/joy2key-1.6.3-r1.ebuild
new file mode 100644
index 000000000000..38c8331331cf
--- /dev/null
+++ b/app-misc/joy2key/joy2key-1.6.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An application that translates joystick events to keyboard events"
+HOMEPAGE="https://sourceforge.net/projects/joy2key"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libX11
+ x11-apps/xwininfo )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )"
+
+src_configure() {
+ econf --disable-dependency-tracking $(use_enable X)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog joy2keyrc.sample rawscancodes README TODO
+}