summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-09-17 17:58:25 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-17 18:02:41 +0200
commitb3221ab2ce4c636141425633d268994fa384561c (patch)
tree04bc644921e8a41722ceffb8efbbc821197cd14a /app-misc/tmux2html/tmux2html-0.1.11.ebuild
parentsci-physics/root: apply fixes from live ebuild to 6.14 (diff)
downloadgentoo-b3221ab2ce4c636141425633d268994fa384561c.tar.gz
gentoo-b3221ab2ce4c636141425633d268994fa384561c.tar.bz2
gentoo-b3221ab2ce4c636141425633d268994fa384561c.zip
app-misc/tmux2html: new package.
tmux2html is a Python script to render full tmux windows or individual panes as a single HTML page. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-misc/tmux2html/tmux2html-0.1.11.ebuild')
-rw-r--r--app-misc/tmux2html/tmux2html-0.1.11.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-misc/tmux2html/tmux2html-0.1.11.ebuild b/app-misc/tmux2html/tmux2html-0.1.11.ebuild
new file mode 100644
index 000000000000..81bf38621577
--- /dev/null
+++ b/app-misc/tmux2html/tmux2html-0.1.11.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Render full tmux windows or individual panes as HTML"
+HOMEPAGE="https://github.com/tweekmonster/tmux2html"
+SRC_URI="https://github.com/tweekmonster/tmux2html/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-misc/tmux
+ dev-python/setuptools[${PYTHON_USEDEP}]"