summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-28 18:19:56 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-28 18:19:56 +0100
commit03ccd4575abb0c9e3f7af84c4092fdde0444e6de (patch)
tree4a3e49c5d17ab023629b46df4c4a702672361068 /app-misc
parentsys-devel/gcc: add 10.3.1_p20211126 (diff)
downloadgentoo-03ccd4575abb0c9e3f7af84c4092fdde0444e6de.tar.gz
gentoo-03ccd4575abb0c9e3f7af84c4092fdde0444e6de.tar.bz2
gentoo-03ccd4575abb0c9e3f7af84c4092fdde0444e6de.zip
app-misc/fmawk: new package; add version 1.2 and live
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fmawk/Manifest1
-rw-r--r--app-misc/fmawk/fmawk-1.2.ebuild42
-rw-r--r--app-misc/fmawk/fmawk-9999.ebuild38
-rw-r--r--app-misc/fmawk/metadata.xml18
4 files changed, 99 insertions, 0 deletions
diff --git a/app-misc/fmawk/Manifest b/app-misc/fmawk/Manifest
new file mode 100644
index 000000000000..05308c04d54f
--- /dev/null
+++ b/app-misc/fmawk/Manifest
@@ -0,0 +1 @@
+DIST fmawk-1.2.tar.gz 23399 BLAKE2B f4c20c8f1569a6715710a5cef02a767152694ef7e216c9fe707c7ac57c20dd012189db14777d47a980008255c7f51b5c165cdf086c41835a7ce550b758a8f350 SHA512 86d56e1cc893c385a0bb338957a9ef698c0edef4587e6d3a21aa316fd996fa3b1416220e5c235d613876a3d19650e8e7a20bf991a4ce67ce9759a362d2aaac30
diff --git a/app-misc/fmawk/fmawk-1.2.ebuild b/app-misc/fmawk/fmawk-1.2.ebuild
new file mode 100644
index 000000000000..2247b8c0dff1
--- /dev/null
+++ b/app-misc/fmawk/fmawk-1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="File manager written in awk"
+HOMEPAGE="https://github.com/huijunchen9260/fm.awk/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/huijunchen9260/fm.awk.git"
+else
+ SRC_URI="https://github.com/huijunchen9260/fm.awk/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/fm.awk-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="virtual/awk"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local bin
+ for bin in fm.awk fmawk fmawk-previewer; do
+ dobin ${bin}
+ done
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "PDFs preview" app-text/poppler
+ optfeature "images preview" media-gfx/chafa
+ optfeature "videos preview" media-video/ffmpegthumbnailer
+}
diff --git a/app-misc/fmawk/fmawk-9999.ebuild b/app-misc/fmawk/fmawk-9999.ebuild
new file mode 100644
index 000000000000..9500af6a4ee7
--- /dev/null
+++ b/app-misc/fmawk/fmawk-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="File manager written in awk"
+HOMEPAGE="https://github.com/huijunchen9260/fm.awk/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/huijunchen9260/fm.awk.git"
+else
+ SRC_URI="https://github.com/huijunchen9260/fm.awk/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/fm.awk-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="virtual/awk"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "PDFs preview" app-text/poppler
+ optfeature "images preview" media-gfx/chafa
+ optfeature "videos preview" media-video/ffmpegthumbnailer
+}
diff --git a/app-misc/fmawk/metadata.xml b/app-misc/fmawk/metadata.xml
new file mode 100644
index 000000000000..a2080c646539
--- /dev/null
+++ b/app-misc/fmawk/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ FMAWK is a experimental file manager written almost entirely
+ in the awk programming language. Thought written in awk it is comparable
+ with features to ranger or nnn.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/huijunchen9260/fm.awk/issues</bugs-to>
+ <remote-id type="github">huijunchen9260/fm.awk</remote-id>
+ </upstream>
+</pkgmetadata>