summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2019-07-24 22:02:59 +1000
committerMichael Palimaka <kensington@gentoo.org>2019-07-24 22:07:07 +1000
commit461cc79c045c0f31db2b5c251405f2789027d66e (patch)
tree7bd4322b50127c0acaf35d47defb0049d5f58fdb /app-misc
parentsys-fs/lvm2: use /bin/bash as CONFIG_SHELL (diff)
downloadgentoo-461cc79c045c0f31db2b5c251405f2789027d66e.tar.gz
gentoo-461cc79c045c0f31db2b5c251405f2789027d66e.tar.bz2
gentoo-461cc79c045c0f31db2b5c251405f2789027d66e.zip
app-misc/ytree: revision bump
* Port to EAPI 7 * Fix build with sys-libs/ncurses[tinfo] * Stop installing pre-compressed man page Closes: https://bugs.gentoo.org/690348 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ytree/files/ytree-1.99-tinfo.patch15
-rw-r--r--app-misc/ytree/ytree-1.99_p1-r1.ebuild42
2 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/ytree/files/ytree-1.99-tinfo.patch b/app-misc/ytree/files/ytree-1.99-tinfo.patch
new file mode 100644
index 000000000000..9656cce88d51
--- /dev/null
+++ b/app-misc/ytree/files/ytree-1.99-tinfo.patch
@@ -0,0 +1,15 @@
+Fix build sys-libs/ncurses[tinfo]
+
+Bug: https://bugs.gentoo.org/690348
+
+--- a/Makefile
++++ b/Makefile
+@@ -33,7 +33,7 @@
+ #CLOCK = -DCLOCK_SUPPORT # Experimental!
+ READLINE = -DREADLINE_SUPPORT
+ CFLAGS += -D_GNU_SOURCE $(COLOR) $(CLOCK) $(READLINE) $(ADD_CFLAGS)
+-LDFLAGS += -lncurses -lreadline
++LDFLAGS += `pkg-config --libs ncurses` -lreadline
+
+ ###########################
+ # LINUX with Wide character support (testet with ncurses 5.4)
diff --git a/app-misc/ytree/ytree-1.99_p1-r1.ebuild b/app-misc/ytree/ytree-1.99_p1-r1.ebuild
new file mode 100644
index 000000000000..2f5d5986175b
--- /dev/null
+++ b/app-misc/ytree/ytree-1.99_p1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-1.99pl1"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A curses-based file manager"
+HOMEPAGE="http://www.han.de/~werner/ytree.html"
+SRC_URI="http://www.han.de/~werner/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.94-bindir.patch"
+ "${FILESDIR}/${PN}-1.99-tinfo.patch"
+)
+
+DOCS=( CHANGES README THANKS ytree.conf )
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_install() {
+ einstalldocs
+ dobin ${PN}
+ doman ${PN}.1
+}