summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-24 05:13:16 +0100
committerSam James <sam@gentoo.org>2024-10-24 05:13:16 +0100
commit7e9d9a57a2323cd2c0c729ee3b478ab93fd9c24d (patch)
tree887a0876a77f111032fbedeb5ad6107a117ba7d3 /app-misc
parentdev-debug/dtrace: keyword 2.0.1.1-r2 for ~arm64 (diff)
downloadgentoo-7e9d9a57a2323cd2c0c729ee3b478ab93fd9c24d.tar.gz
gentoo-7e9d9a57a2323cd2c0c729ee3b478ab93fd9c24d.tar.bz2
gentoo-7e9d9a57a2323cd2c0c729ee3b478ab93fd9c24d.zip
app-misc/tmux: add 3.5a
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tmux/Manifest1
-rw-r--r--app-misc/tmux/tmux-3.5a.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/app-misc/tmux/Manifest b/app-misc/tmux/Manifest
index 39ed047c0516..f4c797e34a89 100644
--- a/app-misc/tmux/Manifest
+++ b/app-misc/tmux/Manifest
@@ -1,4 +1,5 @@
DIST tmux-3.3a.tar.gz 677448 BLAKE2B e835ce0f136175521035a684419f221864edb0a9506d7d68cbc0239b1349e78949ebd96573a9d8651a2df6d99acb433075d6e0c20d7394a53fe6b44bd9e56069 SHA512 29a846df7d93601c42a22f84f606931dc65da1f70b67d351d0425f77ea3affe3e8218b2940d42cd3dadf3cd1aa95032daad3ecb14fbff0f69939d1beae0498c7
DIST tmux-3.4.tar.gz 707213 BLAKE2B 2b1990b95d7439702e9287402d9828d4ecab573202c099aa482969c047b540d4b899f79d87587fc712e727d9cebf5fa7393512087e469fc355b4a30b1894e229 SHA512 bd3880211d99d8ee15947000abf8a1832fdfa48b29b2df81b66d5969cf3f4e64e746f984f6139bfc57e3ebee7fe8dc7cbb6bccb779307607de6c376969fecbff
DIST tmux-3.5.tar.gz 715322 BLAKE2B 6c257e7c3b2f49ae2a54dd28c8d89d4832ad1eb3a49e800ff83a03fd4e620bdee695845b1c272cff25f0805502c1309e9d14faae6ca3fb4d4f050d9abf4aeae9 SHA512 bb3ca1ae8b330c3efc8fcbe8a65a40f78beadaf08c79265f6377c4187d26028e485e5404b832bbea16b170fd9bbdf2f1554d67dd3b1289e183fca19df460b695
+DIST tmux-3.5a.tar.gz 715619 BLAKE2B 2314bc127f805071c9f2fe28be549b0948042a153aa68d997efc1dc0d6eba198b04aa16932d0a84b03250567100fb81c464919fcc8ba98660d3d0750ff5fe879 SHA512 2383e99aec2dcdb1d899793d5ecab40a68b921194f84770d3f4d19712bfc85590657a99d2a9a7bec36d4ba5ab39fa713f13937b0acad3b61cd9b2302dba61d43
DIST tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b 458 BLAKE2B 04143e6d1cfbbd467f1656f949363cb7a4a3e16e9b3cf56b8b0423babe56276abee2622964cb490005fc76d1cbe12201fb1a6446a6f860c2cc1ff3c9bd5fc496 SHA512 fe0aca7d03067af87e0788a2fa902c7ef5500ba72295cb63c5a1814534a008c224256d7f890ac1af6d17f3734b45148765e1632f075e284c453185df2927b979
diff --git a/app-misc/tmux/tmux-3.5a.ebuild b/app-misc/tmux/tmux-3.5a.ebuild
new file mode 100644
index 000000000000..037e0d2ba17e
--- /dev/null
+++ b/app-misc/tmux/tmux-3.5a.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="https://tmux.github.io/"
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b"
+ EGIT_REPO_URI="https://github.com/tmux/tmux.git"
+else
+ SRC_URI="https://github.com/tmux/tmux/releases/download/${PV}/${P/_/-}.tar.gz"
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ fi
+ S="${WORKDIR}/${P/_/-}"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="debug jemalloc selinux systemd utempter vim-syntax"
+
+DEPEND="
+ dev-libs/libevent:=
+ sys-libs/ncurses:=
+ jemalloc? ( dev-libs/jemalloc:= )
+ systemd? ( sys-apps/systemd:= )
+ utempter? ( sys-libs/libutempter )
+ kernel_Darwin? ( dev-libs/libutf8proc:= )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ app-alternatives/yacc
+"
+
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-screen )
+ vim-syntax? ( app-vim/vim-tmux )
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # BSD only functions
+ strtonum recallocarray
+ # missing on musl, tmux has fallback impl which it uses
+ b64_ntop
+)
+
+DOCS=( CHANGES README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4-flags.patch
+ "${FILESDIR}"/${PN}-3.5-fix-xterm-sym.patch # merged upstream
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # bug 438558
+ # 1.7 segfaults when entering copy mode if compiled with -Os
+ replace-flags -Os -O2
+
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc
+ $(use_enable debug)
+ $(use_enable jemalloc)
+ $(use_enable systemd)
+ $(use_enable utempter)
+
+ # For now, we only expose this for macOS, because
+ # upstream strongly encourage it. I'm not sure it's
+ # needed on Linux right now.
+ $(use_enable kernel_Darwin utf8proc)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ einstalldocs
+
+ dodoc example_tmux.conf
+ docompress -x /usr/share/doc/${PF}/example_tmux.conf
+
+ if use systemd; then
+ systemd_newuserunit "${FILESDIR}"/tmux.service tmux@.service
+ systemd_newuserunit "${FILESDIR}"/tmux.socket tmux@.socket
+ fi
+}