summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-12-02 07:03:33 -0800
committerSam James <sam@gentoo.org>2024-12-03 09:12:33 +0000
commit9feb11cd6b86981da4c807846db2269080d20263 (patch)
tree87c8ccf45afcb9a518b445f3543c8ecdfa2ab61c /app-misc
parentdev-util/qbs: add 2.5.0 (diff)
downloadgentoo-9feb11cd6b86981da4c807846db2269080d20263.tar.gz
gentoo-9feb11cd6b86981da4c807846db2269080d20263.tar.bz2
gentoo-9feb11cd6b86981da4c807846db2269080d20263.zip
app-misc/jq: fix insecure RUNPATH
[sam: Add revbump.] Closes: https://bugs.gentoo.org/945698 Fixes: df24c1f97695d8a64a82577cd785e85ebe7ad4e7 Upstream-PR: https://github.com/jqlang/jq/pull/3212 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/39565 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/jq/files/jq-1.7-runpath.patch17
-rw-r--r--app-misc/jq/files/jq-1.7.1-runpath.patch38
-rw-r--r--app-misc/jq/jq-1.7.1-r1.ebuild (renamed from app-misc/jq/jq-1.7.1.ebuild)2
3 files changed, 39 insertions, 18 deletions
diff --git a/app-misc/jq/files/jq-1.7-runpath.patch b/app-misc/jq/files/jq-1.7-runpath.patch
deleted file mode 100644
index a8f76f7c90e1..000000000000
--- a/app-misc/jq/files/jq-1.7-runpath.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 0441d4a..8f1aa23 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -283,4 +283,11 @@ AC_SUBST([BUNDLER], ["$bundle_cmd"])
- AC_CONFIG_MACRO_DIR([config/m4])
- AC_CONFIG_FILES([Makefile libjq.pc])
- AC_OUTPUT
--
-+AC_ARG_ENABLE([rpathhack],
-+ [AC_HELP_STRING([--enable-rpathhack], [patch libtool to remove RPATH])],
-+ [
-+AC_MSG_RESULT([patching libtool to fix rpath])
-+sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
-+sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
-+ ],
-+ [])
diff --git a/app-misc/jq/files/jq-1.7.1-runpath.patch b/app-misc/jq/files/jq-1.7.1-runpath.patch
new file mode 100644
index 000000000000..542218ca24c2
--- /dev/null
+++ b/app-misc/jq/files/jq-1.7.1-runpath.patch
@@ -0,0 +1,38 @@
+Fixes: https://github.com/gentoo/gentoo/commit/df24c1f97695d8a64a82577cd785e85ebe7ad4e7
+Upstream-PR: https://github.com/jqlang/jq/pull/3212
+
+From f23a7373d079a4d4fd1f975936e81f35a66dfe84 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Mon, 2 Dec 2024 09:46:33 -0800
+Subject: [PATCH] build: fix insecure RUNPATH
+
+In Gentoo -static-libtool-libs causes a QA Notice.
+
+ * QA Notice: The following files contain insecure RUNPATHs
+ * Please file a bug about this at https://bugs.gentoo.org/
+ * with the maintainer of the package.
+ * /var/tmp/portage/app-misc/jq-1.7.1/image/usr/bin/jqn RPATH: /var/tmp/portage/app-misc/jq-1.7.1/work/jq-jq-1.7.1/.libs
+
+Gentoo-Issue: https://bugs.gentoo.org/945698
+Signed-off-by: orbea <orbea@riseup.net>
+---
+ Makefile.am | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index a183477fde..3f36993c0a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -132,11 +132,10 @@ CLEANFILES = src/version.h .remake-version-h src/builtin.inc src/config_opts.inc
+
+ bin_PROGRAMS = jq
+ jq_SOURCES = src/main.c src/version.h
+-jq_LDFLAGS = -static-libtool-libs
+ jq_LDADD = libjq.la -lm
+
+ if ENABLE_ALL_STATIC
+-jq_LDFLAGS += -all-static
++jq_LDFLAGS = -all-static
+ endif
+
+ ### Tests (make check)
diff --git a/app-misc/jq/jq-1.7.1.ebuild b/app-misc/jq/jq-1.7.1-r1.ebuild
index 75a18f279527..e828ea52bd3e 100644
--- a/app-misc/jq/jq-1.7.1.ebuild
+++ b/app-misc/jq/jq-1.7.1-r1.ebuild
@@ -30,6 +30,7 @@ RDEPEND="
"
PATCHES=(
"${FILESDIR}"/jq-1.6-r3-never-bundle-oniguruma.patch
+ "${FILESDIR}"/jq-1.7.1-runpath.patch
)
RESTRICT="!test? ( test )"
@@ -58,7 +59,6 @@ src_configure() {
--disable-docs
--disable-valgrind
--disable-maintainer-mode
- --enable-rpathhack
$(use_enable static-libs static)
$(use_with oniguruma oniguruma yes)
)