summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-17 18:44:44 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-17 18:27:16 -0400
commitc13ac3781f4db029646fa47148a8f8b02daa5ccb (patch)
treeb6b1cd8a49a67c96a738485f519f2fe3a1577db5 /app-misc
parentmedia-gfx/eog: Version bump to 45.0 (diff)
downloadgentoo-c13ac3781f4db029646fa47148a8f8b02daa5ccb.tar.gz
gentoo-c13ac3781f4db029646fa47148a8f8b02daa5ccb.tar.bz2
gentoo-c13ac3781f4db029646fa47148a8f8b02daa5ccb.zip
app-misc/gnote: Version bump to 45_rc
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32890 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gnote/Manifest1
-rw-r--r--app-misc/gnote/gnote-45_rc.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index eb4f6120021f..935de1f3ae69 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1,3 +1,4 @@
DIST gnote-44.1.tar.xz 3330072 BLAKE2B ff86fa34bdfff61eceb25abef1c73377f888082e70e539172849bf9425eada1c11000c1a75f69eb74fdbc2fc6d45ad3c58c843bf769279a026dd5298a07abc68 SHA512 89364d161d6ecc11822b89dec0353d0e20bc08d883573f324e4980ff2420361ddeb326213eb668fba4ce8de7d5d9668a1a058666ad2b81658ef94f8a65b87363
DIST gnote-45.alpha.tar.xz 3320968 BLAKE2B d53d16f97cb737159c2888d0ffb3f4f6ec1f759a927ed4a50c2abb9ac0c9162e811cf976383c23a4f642b08370037d8d00197e6628528bff51ae1cc93803c07e SHA512 479dfe13cf1680bfdc65cb3ffc40c27bedf11519d38142a276e019062030e946d9a2b10badb0a230d1818aad665c1704e5f9bf8592fff11f9a0f0a6374fade1e
DIST gnote-45.beta.tar.xz 3248536 BLAKE2B 2730ae4addd80ec4eb4777786952595ab2d422eb55832f66cb5d86dbdbc4572f9249984b3270ec69ee236c1acb5063e6fec8529cbaf0930821ac73c6e0c69e4a SHA512 1d3394a00720e334af695182abfc7e39ea5cd94e7958d5e53173c0f6f1b93f242118415bbd7f886edbb8ceb805e6b73835f851e3614db76f113478e85b97ed7a
+DIST gnote-45.rc.tar.xz 3273864 BLAKE2B 8ab5340e0659c4119c279dd1130fd1a591dd496c8eb96cbfe8171f02192a86a5a3cf6b8c075fd195373885271585c1e6ece1af8fdeb0b75442ddc911b29a7b6f SHA512 cb7b8b47ee724f206258b2dd72fb79c5da45c1f3bd1eca754adc57e8f6f9620a98c56d96867ed455511b78d6dac0d6ecac6968bb29e1964aeac233ff191c6072
diff --git a/app-misc/gnote/gnote-45_rc.ebuild b/app-misc/gnote/gnote-45_rc.ebuild
new file mode 100644
index 000000000000..62d3c9902709
--- /dev/null
+++ b/app-misc/gnote/gnote-45_rc.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.74:2[dbus]
+ >=dev-cpp/glibmm-2.74:2.68
+ >=dev-cpp/gtkmm-4.0.0:4.0
+ >=app-crypt/libsecret-0.8
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16
+ test? ( dev-libs/unittest++ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Build system requires UnitTest++ >=1.5.1, but the .pc file doesn't
+ # specify a version
+ sed -i -e "/UnitTest++/ s/version: [^,]*,//" meson.build || die
+ if ! use test; then
+ sed -i -e "/unit_test_pp/ s/ = .*/ = disabler()/" meson.build || die
+ fi
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}