summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2021-05-07 14:55:28 +0000
committerThomas Deutschmann <whissi@gentoo.org>2021-05-11 17:47:29 +0200
commitfe2b0906b83cc5cb3396153132e150e8322fc611 (patch)
treea5011762f7dfee8821180511d0474c31b730b8b9 /app-misc
parentsys-apps/smartmontools: stable 7.2 for hppa/sparc, bug #783825 (diff)
downloadgentoo-fe2b0906b83cc5cb3396153132e150e8322fc611.tar.gz
gentoo-fe2b0906b83cc5cb3396153132e150e8322fc611.tar.bz2
gentoo-fe2b0906b83cc5cb3396153132e150e8322fc611.zip
app-misc/elasticsearch: bump to 7.12.1
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/elasticsearch/Manifest1
-rw-r--r--app-misc/elasticsearch/elasticsearch-7.12.1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-misc/elasticsearch/Manifest b/app-misc/elasticsearch/Manifest
index 054f737244f5..4c19d811a8c8 100644
--- a/app-misc/elasticsearch/Manifest
+++ b/app-misc/elasticsearch/Manifest
@@ -1,5 +1,6 @@
DIST elasticsearch-6.8.15.tar.gz 149102328 BLAKE2B 0ce9ba565d751cd27721f3d49dd24761937c3476cee4896ba1a4d84e4fc238296129481f18cad64270fe8af71a043c2e8e583df14f2a084850fb10c93fcea0ef SHA512 c62c4d9d1bb83e10d3e1079f56b834f2f89b1f712c29d9ce7e81786199c71d287ecbf6df158eca56a7af711eafe13dfb276e12b34e1a0a6cf6719e1fbb44a142
DIST elasticsearch-7.10.2-no-jdk-linux-x86_64.tar.gz 164380146 BLAKE2B 16797ed48c4cb6f91ed891014f275ad86a4852579232df1827413389fc9e505327412729f70783750252190a34b0e0d552ec0b5f25f3d0a811724191eccc6568 SHA512 bd3def00af04670ad04556c911ef8c68b639e1c3b621f36a8973d9700f95873d10bc706a4e3a98f892ac59c1b761d56035a236068d6958af772874e428940dc4
DIST elasticsearch-7.12.0-no-jdk-linux-x86_64.tar.gz 173069694 BLAKE2B 5de74b1e6de743246cf48e32254f9646fa25c2820d0be9df886fdefe131a302ddb8906546147f0d284e2fc0faf8cc0238bf854fe1611d28bf1e7cb1518bd4e31 SHA512 205aa2a2fa2ab7eb7b54087420e0123aa97e5456e2e1f31cad9ea7b84be3f9823a2a7c47d4cf1697833e5f795359477d3a3b0ea4955a8f92583cf2228071827e
+DIST elasticsearch-7.12.1-no-jdk-linux-x86_64.tar.gz 173079845 BLAKE2B 98214508c2c1dcb631f59d9e51d5949f9a7c5d1f68ff78c8d93af04c6a21fa1e1c6e2051f04bbdb8154443d6295ad54af2016695fcb9193b7595e1486777ba98 SHA512 c91fd66668977280d7339caf6b4fef9fce5640492f0e2a65bc537c6da8397c801a3727f1ff56b7a1591b11ea47195720c588a4eba473043f829a87cd3dcc0af4
DIST elasticsearch-oss-6.8.15.tar.gz 68240776 BLAKE2B 431d845e02f2118a98021af4422ece34274b6d0811a32c5a3e679da3f8f56ca9cd45949307268811edbb83327a4a80fb84866cbbaaf01f7d3af042412b1e1bfa SHA512 7e6a819339ac6043af218f9d97d5d68c50ac46900e4293e7fa18992f7a50b10b0ab2434e26ff0dc1546204ae7526de8ac6ef6545fc0db9c862ceeaa0d96c56f5
DIST elasticsearch-oss-7.10.2-no-jdk-linux-x86_64.tar.gz 76383466 BLAKE2B e99c04b0d10ef5755986515c7127ebde00b58e0eba69b6a05e12bd0bffee70266bbb023680584bfe0f321d5a3cf79af89cce3a5191923ad721a9f6039ab82743 SHA512 7b63237996569ccdc7c9d9e7cc097fcb23865396eddac30e5f02543484220d2fc70a7285b430877e5e76a5d8716d9682de9fc40d5e57a08f331e82011fc59756
diff --git a/app-misc/elasticsearch/elasticsearch-7.12.1.ebuild b/app-misc/elasticsearch/elasticsearch-7.12.1.ebuild
new file mode 100644
index 000000000000..e2035c21e8ff
--- /dev/null
+++ b/app-misc/elasticsearch/elasticsearch-7.12.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd tmpfiles
+
+DESCRIPTION="Free and Open, Distributed, RESTful Search Engine"
+HOMEPAGE="https://www.elastic.co/elasticsearch/"
+SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}-no-jdk-linux-x86_64.tar.gz"
+LICENSE="Apache-2.0 BSD-2 Elastic-2.0 LGPL-3 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="acct-group/elasticsearch
+ acct-user/elasticsearch
+ virtual/jre"
+
+QA_PREBUILT="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
+QA_PRESTRIPPED="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
+
+src_prepare() {
+ default
+
+ rm LICENSE.txt NOTICE.txt || die
+ rmdir logs || die
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
+
+ insinto /etc/${PN}
+ doins -r config/.
+ rm -r config || die
+
+ fowners root:${PN} /etc/${PN}
+ fperms 2750 /etc/${PN}
+
+ insinto /usr/share/${PN}
+ doins -r .
+
+ exeinto /usr/share/${PN}/bin
+ doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
+
+ fperms -R +x /usr/share/${PN}/bin
+ fperms -R +x /usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ fperms 0750 /var/{lib,log}/${PN}
+ dodir /usr/share/${PN}/plugins
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
+
+ newconfd "${FILESDIR}/${PN}.conf.4" ${PN}
+ newinitd "${FILESDIR}/${PN}.init.8" ${PN}
+
+ systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
+ systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
+
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfiles.d ${PN}.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process /usr/lib/tmpfiles.d/${PN}.conf
+
+ elog
+ elog "You may create multiple instances of ${PN} by"
+ elog "symlinking the init script:"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+ elog
+ elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+ elog "from /etc/${PN} into the configuration directory of the instance:"
+ elog "/etc/${PN}/instance"
+ elog
+ ewarn "Please make sure you have proper permissions on /etc/${PN}"
+ ewarn "prior to keystore generation or you may experience startup fails."
+ ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
+ ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
+}