summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-08-19 17:23:12 +0200
committerJohannes Huber <johu@gentoo.org>2015-08-19 17:23:22 +0200
commit8659a2124a109741fa611d39f5329e4f59b04840 (patch)
tree2e16ce51f0a4fe9a1572d7fbe2f3c5def30a4725 /app-office/calligra/calligra-9999.ebuild
parentapp-office/calligra-l10n: Version bump (diff)
downloadgentoo-8659a2124a109741fa611d39f5329e4f59b04840.tar.gz
gentoo-8659a2124a109741fa611d39f5329e4f59b04840.tar.bz2
gentoo-8659a2124a109741fa611d39f5329e4f59b04840.zip
app-office/calligra: Version bump
Thanks for contributions by Alex Xu (Hello71) <alex_y_xu@yahoo.ca>, Jon <j.scruggs@gmail.com>, Tamas Jantvik <tsjk@hotmail.com>. Gentoo-Bug: 543068 Gentoo-Bug: 549940 Reported-by: Alexandre <alexandre.guimaraes@campus.ul.pt> Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-office/calligra/calligra-9999.ebuild')
-rw-r--r--app-office/calligra/calligra-9999.ebuild77
1 files changed, 35 insertions, 42 deletions
diff --git a/app-office/calligra/calligra-9999.ebuild b/app-office/calligra/calligra-9999.ebuild
index bce7b6d2a7f5..97cea479c13f 100644
--- a/app-office/calligra/calligra-9999.ebuild
+++ b/app-office/calligra/calligra-9999.ebuild
@@ -11,7 +11,6 @@ EAPI=5
CHECKREQS_DISK_BUILD="4G"
KDE_HANDBOOK="optional"
KDE_LINGUAS_LIVE_OVERRIDE="true"
-KDE_MINIMAL="4.13.1"
OPENGL_REQUIRED="optional"
inherit check-reqs kde4-base versionator
@@ -40,13 +39,13 @@ if [[ ${KDE_BUILD_TYPE} == release ]] ; then
KEYWORDS="~amd64 ~arm ~x86"
fi
-IUSE="attica +crypt +eigen +exif fftw +fontconfig freetds +glib +gsf gsl
-import-filter +jpeg jpeg2k +kdcraw kde +kdepim +lcms marble mysql +okular
-openexr +pdf postgres spacenav sybase test tiff +threads +truetype vc xbase
-+xml"
+IUSE="attica color-management +crypt +eigen +exif fftw +fontconfig freetds
++glew +glib +gsf gsl import-filter +jpeg jpeg2k +kdcraw kde +kdepim +lcms
+marble mysql +okular openexr +pdf postgres spacenav sybase test tiff +threads
++truetype vc xbase +xml"
-# please do not sort here, order is same as in CMakeLists.txt
-CAL_FTS="words stage sheets author karbon krita kexi flow plan braindump"
+# Don't use Active, it's broken on desktops.
+CAL_FTS="author braindump flow gemini karbon kexi krita plan sheets stage words"
for cal_ft in ${CAL_FTS}; do
IUSE+=" calligra_features_${cal_ft}"
done
@@ -54,7 +53,8 @@ unset cal_ft
REQUIRED_USE="
calligra_features_author? ( calligra_features_words )
- calligra_features_krita? ( eigen exif lcms )
+ calligra_features_gemini? ( opengl )
+ calligra_features_krita? ( eigen exif lcms opengl )
calligra_features_plan? ( kdepim )
calligra_features_sheets? ( eigen )
vc? ( calligra_features_krita )
@@ -62,28 +62,17 @@ REQUIRED_USE="
"
RDEPEND="
- !app-office/karbon
- !app-office/kexi
- !app-office/koffice-data
- !app-office/koffice-l10n
- !app-office/koffice-libs
- !app-office/koffice-meta
- !app-office/kplato
- !app-office/kpresenter
- !app-office/krita
- !app-office/kspread
- !app-office/kword
$(add_kdeapps_dep knewstuff)
dev-lang/perl
dev-libs/boost
dev-qt/qtcore:4[exceptions]
media-libs/libpng:0
sys-libs/zlib
- >=dev-qt/qtgui-4.8.1-r1:4
virtual/libiconv
attica? ( dev-libs/libattica )
+ color-management? ( media-libs/opencolorio )
crypt? ( app-crypt/qca:2[qt4(+)] )
- eigen? ( dev-cpp/eigen:2 )
+ eigen? ( dev-cpp/eigen:3 )
exif? ( media-gfx/exiv2:= )
fftw? ( sci-libs/fftw:3.0 )
fontconfig? ( media-libs/fontconfig )
@@ -97,6 +86,7 @@ RDEPEND="
app-text/libwpd:*
app-text/libwpg:*
app-text/libwps
+ dev-libs/librevenge
media-libs/libvisio
)
jpeg? ( virtual/jpeg:0 )
@@ -124,14 +114,14 @@ RDEPEND="
dev-db/postgresql:*
dev-libs/libpqxx
)
- spacenav? ( dev-libs/libspnav )
+ spacenav? ( dev-libs/libspnav )
sybase? ( dev-db/freetds )
tiff? ( media-libs/tiff:0 )
truetype? ( media-libs/freetype:2 )
vc? ( dev-libs/vc )
xbase? ( dev-db/xbase )
calligra_features_kexi? (
- >=dev-db/sqlite-3.7.9:3[extensions(+)]
+ >=dev-db/sqlite-3.8.7:3[extensions(+)]
dev-libs/icu:=
)
calligra_features_krita? (
@@ -141,13 +131,17 @@ RDEPEND="
)
calligra_features_words? ( dev-libs/libxslt )
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ x11-misc/shared-mime-info
+"
-[[ ${PV} == 9999 ]] && LANGVERSION="2.4" || LANGVERSION="$(get_version_component_range 1-2)"
+[[ ${PV} == 9999 ]] && LANGVERSION="2.9" || LANGVERSION="$(get_version_component_range 1-2)"
PDEPEND=">=app-office/calligra-l10n-${LANGVERSION}"
-RESTRICT=test
# bug 394273
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}/${PN}-2.9.6-ghns-linking.patch" )
pkg_pretend() {
check-reqs_pkg_pretend
@@ -159,19 +153,23 @@ pkg_setup() {
}
src_configure() {
- local cal_ft
+ local cal_ft myproducts
+
+ # applications
+ for cal_ft in ${CAL_FTS}; do
+ use calligra_features_${cal_ft} && myproducts+=( ${cal_ft^^} )
+ done
+
+ local mycmakeargs=( -DPRODUCTSET="${myproducts[*]}" )
# first write out things we want to hard-enable
- local mycmakeargs=(
- "-DWITH_PNG=ON"
- "-DWITH_ZLIB=ON"
+ mycmakeargs+=(
"-DGHNS=ON"
"-DWITH_Iconv=ON" # available on all supported arches and many more
)
# default disablers
mycmakeargs+=(
- "-DBUILD_active=OFF" # we dont support active gui, maybe arm could
"-DCREATIVEONLY=OFF"
"-DPACKAGERS_BUILD=OFF"
"-DWITH_Soprano=OFF"
@@ -180,8 +178,9 @@ src_configure() {
# regular options
mycmakeargs+=(
$(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with color-management OCIO)
$(cmake-utils_use_with crypt QCA2)
- $(cmake-utils_use_with eigen Eigen2)
+ $(cmake-utils_use_with eigen Eigen3)
$(cmake-utils_use_with exif Exiv2)
$(cmake-utils_use_with fftw FFTW3)
$(cmake-utils_use_with fontconfig Fontconfig)
@@ -190,6 +189,7 @@ src_configure() {
$(cmake-utils_use_with gsl GSL)
$(cmake-utils_use_with import-filter LibEtonyek)
$(cmake-utils_use_with import-filter LibOdfGen)
+ $(cmake-utils_use_with import-filter LibRevenge)
$(cmake-utils_use_with import-filter LibVisio)
$(cmake-utils_use_with import-filter LibWpd)
$(cmake-utils_use_with import-filter LibWpg)
@@ -200,15 +200,14 @@ src_configure() {
$(cmake-utils_use_with kde KActivities)
$(cmake-utils_use_with kdepim KdepimLibs)
$(cmake-utils_use_with lcms LCMS2)
- $(cmake-utils_use_with marble Marble)
+ $(cmake-utils_use_with marble CalligraMarble)
$(cmake-utils_use_with mysql MySQL)
$(cmake-utils_use_with okular Okular)
$(cmake-utils_use_with openexr OpenEXR)
- $(cmake-utils_use_with opengl GLEW)
- $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use opengl USEOPENGL)
$(cmake-utils_use_with pdf Poppler)
$(cmake-utils_use_with pdf Pstoedit)
- $(cmake-utils_use_with postgres PostgreSQL)
+ $(cmake-utils_use_with postgres CalligraPostgreSQL)
$(cmake-utils_use_build postgres pqxx)
$(cmake-utils_use_with spacenav Spnav)
$(cmake-utils_use_with sybase FreeTDS)
@@ -219,13 +218,7 @@ src_configure() {
$(cmake-utils_use_with xbase XBase)
)
- # applications
- for cal_ft in ${CAL_FTS}; do
- mycmakeargs+=( $(cmake-utils_use_build calligra_features_${cal_ft} ${cal_ft}) )
- done
mycmakeargs+=( $(cmake-utils_use_build test cstester) )
- # filters
-
kde4-base_src_configure
}