summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Castagnino <casta@xwing.info>2021-06-30 10:00:20 +0200
committerMatt Turner <mattst88@gentoo.org>2021-07-04 11:10:15 -0700
commit3cf6a44731f195a7bedee64e79f841c8c16cf4eb (patch)
tree035777bbe3feeda54389b857d0b7026cc8043081 /app-office/grisbi/grisbi-2.0.4.ebuild
parentx11-misc/xkeyboard-config: Version bump to 2.33 (diff)
downloadgentoo-3cf6a44731f195a7bedee64e79f841c8c16cf4eb.tar.gz
gentoo-3cf6a44731f195a7bedee64e79f841c8c16cf4eb.tar.bz2
gentoo-3cf6a44731f195a7bedee64e79f841c8c16cf4eb.zip
app-office/grisbi: Version bump to 2.0.4
Closes: https://bugs.gentoo.org/797595 Closes: https://github.com/gentoo/gentoo/pull/21483 Signed-off-by: Guillaume Castagnino <casta@xwing.info> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-office/grisbi/grisbi-2.0.4.ebuild')
-rw-r--r--app-office/grisbi/grisbi-2.0.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-office/grisbi/grisbi-2.0.4.ebuild b/app-office/grisbi/grisbi-2.0.4.ebuild
new file mode 100644
index 000000000000..5fc8d7898b3c
--- /dev/null
+++ b/app-office/grisbi/grisbi-2.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="Grisbi is a personal accounting application for Linux"
+HOMEPAGE="http://www.grisbi.org https://github.com/grisbi/grisbi"
+SRC_URI="mirror://sourceforge/${PN}/grisbi%20stable/2.0.x/${P}.tar.bz2"
+IUSE="goffice nls ofx ssl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.5:2
+ >=dev-libs/glib-2.44.0:2
+ >=x11-libs/gtk+-3.20:3
+ x11-misc/xdg-utils
+ >=gnome-extra/libgsf-1.14
+ ssl? ( >=dev-libs/openssl-1.0.0:0= )
+ ofx? ( >=dev-libs/libofx-0.9.0:= )
+ goffice? ( >=x11-libs/goffice-0.10.0 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --with-libxml2 \
+ --without-cunit \
+ --disable-static \
+ $(use_with ssl openssl) \
+ $(use_with ofx) \
+ $(use_with goffice) \
+ $(use_enable nls)
+}