summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-14 20:42:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-14 20:55:04 +0100
commitd9d6ce294d0657b3393b30d85792a27c064ec6f3 (patch)
treea901ee600755bcdfc057f487b57e3bc9112f900b /app-office/libreoffice
parentapp-office/libreoffice: Use --enable-mergelibs=more (diff)
downloadgentoo-d9d6ce294d0657b3393b30d85792a27c064ec6f3.tar.gz
gentoo-d9d6ce294d0657b3393b30d85792a27c064ec6f3.tar.bz2
gentoo-d9d6ce294d0657b3393b30d85792a27c064ec6f3.zip
app-office/libreoffice: Fix install Qt6/KF6 vcl plugin w/o Qt5/KF5
See also: https://gerrit.libreoffice.org/c/core/+/163313 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/libreoffice')
-rw-r--r--app-office/libreoffice/files/libreoffice-24.2-kf6-configure.patch61
-rw-r--r--app-office/libreoffice/libreoffice-24.2.1.1.ebuild7
2 files changed, 65 insertions, 3 deletions
diff --git a/app-office/libreoffice/files/libreoffice-24.2-kf6-configure.patch b/app-office/libreoffice/files/libreoffice-24.2-kf6-configure.patch
new file mode 100644
index 000000000000..2a4952d7e7cc
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-24.2-kf6-configure.patch
@@ -0,0 +1,61 @@
+From ec69b448f4b6296edb6b28ced5ecb710be82438b Mon Sep 17 00:00:00 2001
+From: Michael Weghorn <m.weghorn@posteo.de>
+Date: Tue, 13 Feb 2024 16:25:35 +0100
+Subject: [PATCH] scp2: Take ENABLE_{KF,QT}6 into account
+
+The qt6 and kf6 VCL plugins are also part
+of the kde install set, so take
+`ENABLE_QT6` and `ENABLE_KF6` into
+account when deciding whether to install
+it.
+
+This makes packaging these VCL plugins work
+when building with `--enable-qt6` and/or
+`--enable-kf6`, but without `--enable-qt5`
+and `--enable-kf5`.
+
+Command that can be used for testing:
+
+ make DESTDIR=/tmp/dummy distro-pack-install -o build -o check
+
+(Then, check whether the "installation" in /tmp/dummy
+contains the VCL plugins as expected.)
+
+Thanks to Andreas Sturmlechner for reporting
+the issue on IRC #libreoffice-dev on 2024-02-12.
+
+Change-Id: Ieea67468e3388f8b7b66f53221574c6225516b44
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/163313
+Tested-by: Jenkins
+Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
+---
+ scp2/InstallScript_setup_osl.mk | 2 +-
+ scp2/Module_scp2.mk | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/scp2/InstallScript_setup_osl.mk b/scp2/InstallScript_setup_osl.mk
+index 6f7b58204225e..cf69165c1b60f 100644
+--- a/scp2/InstallScript_setup_osl.mk
++++ b/scp2/InstallScript_setup_osl.mk
+@@ -36,7 +36,7 @@ $(eval $(call gb_InstallScript_use_modules,setup_osl,\
+ $(if $(filter TRUE,$(ENABLE_EVOAB2) $(ENABLE_GIO) $(ENABLE_GTK3)),\
+ scp2/gnome \
+ ) \
+- $(if $(filter TRUE,$(ENABLE_QT5) $(ENABLE_KF5) $(ENABLE_GTK3_KDE5)),\
++ $(if $(filter TRUE,$(ENABLE_QT5) $(ENABLE_QT6) $(ENABLE_KF5) $(ENABLE_KF6) $(ENABLE_GTK3_KDE5)),\
+ scp2/kde \
+ ) \
+ $(if $(filter TRUE,$(ENABLE_ONLINE_UPDATE)),\
+diff --git a/scp2/Module_scp2.mk b/scp2/Module_scp2.mk
+index 25ae8167df561..651413fa2c17e 100644
+--- a/scp2/Module_scp2.mk
++++ b/scp2/Module_scp2.mk
+@@ -40,7 +40,7 @@ $(eval $(call gb_Module_add_targets,scp2,\
+ $(if $(filter TRUE,$(ENABLE_EVOAB2) $(ENABLE_GIO) $(ENABLE_GTK3)),\
+ InstallModule_gnome \
+ ) \
+- $(if $(filter TRUE,$(ENABLE_QT5) $(ENABLE_KF5) $(ENABLE_GTK3_KDE5)),\
++ $(if $(filter TRUE,$(ENABLE_QT5) $(ENABLE_QT6) $(ENABLE_KF5) $(ENABLE_KF6) $(ENABLE_GTK3_KDE5)),\
+ InstallModule_kde \
+ ) \
+ ))
diff --git a/app-office/libreoffice/libreoffice-24.2.1.1.ebuild b/app-office/libreoffice/libreoffice-24.2.1.1.ebuild
index 588451cdcb06..c9eed10d3c29 100644
--- a/app-office/libreoffice/libreoffice-24.2.1.1.ebuild
+++ b/app-office/libreoffice/libreoffice-24.2.1.1.ebuild
@@ -313,12 +313,13 @@ PATCHES=(
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
"${FILESDIR}/${PN}-24.2-qtdetect.patch"
- # not yet upstream, sourced from Mandriva
- "${FILESDIR}/${PN}-24.2-kf6-buildfix.patch"
-
# maybe upstreamable
"${FILESDIR}/${PN}-7.5.8.2-icu-74-compatibility.patch"
+ # git master, pending 24.2
+ "${FILESDIR}/${PN}-24.2-kf6-configure.patch"
+ "${FILESDIR}/${PN}-24.2-kf6-buildfix.patch"
+
)
S="${WORKDIR}/${PN}-${MY_PV}"