summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:11:38 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:09:43 +0100
commit4d5488805f946525a7132f199770c3a7a4a3d066 (patch)
tree4fd37c7e06003be50df41f36d84976e8ce3d4693 /app-shells
parentapp-office/magicpoint: tidy up patch, respect ${PKG_CONFIG} and add dep (diff)
downloadgentoo-4d5488805f946525a7132f199770c3a7a4a3d066.tar.gz
gentoo-4d5488805f946525a7132f199770c3a7a4a3d066.tar.bz2
gentoo-4d5488805f946525a7132f199770c3a7a4a3d066.zip
app-shells/hstr: respect ${PKG_CONFIG}
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/hstr/files/hstr-2.0-fix-ncurses-configure.patch14
-rw-r--r--app-shells/hstr/hstr-2.0.ebuild12
-rw-r--r--app-shells/hstr/hstr-2.1.ebuild12
-rw-r--r--app-shells/hstr/hstr-2.2.ebuild17
4 files changed, 35 insertions, 20 deletions
diff --git a/app-shells/hstr/files/hstr-2.0-fix-ncurses-configure.patch b/app-shells/hstr/files/hstr-2.0-fix-ncurses-configure.patch
index 215fd5cedfc9..9b5c089b67d8 100644
--- a/app-shells/hstr/files/hstr-2.0-fix-ncurses-configure.patch
+++ b/app-shells/hstr/files/hstr-2.0-fix-ncurses-configure.patch
@@ -1,5 +1,3 @@
-diff --git a/configure.ac b/configure.ac
-index 1676ec8..73c8be5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,39 +47,33 @@ then
@@ -44,14 +42,14 @@ index 1676ec8..73c8be5 100644
+if pkg-config --exists ncursesw
+then
+ AC_MSG_NOTICE([Module ncursesw found])
-+ NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
-+ NCURSESW_LIBS=`pkg-config --libs ncursesw`
++ NCURSESW_CFLAGS=`${PKG_CONFIG} --cflags ncursesw`
++ NCURSESW_LIBS=`${PKG_CONFIG} --libs ncursesw`
+else
-+ if pkg-config --exists ncurses
++ if ${PKG_CONFIG} --exists ncurses
+ then
+ AC_MSG_NOTICE([Module ncurses found])
-+ NCURSESW_CFLAGS=`pkg-config --cflags ncursesw`
-+ NCURSESW_LIBS=`pkg-config --libs ncurses`
++ NCURSESW_CFLAGS=`${PKG_CONFIG} --cflags ncursesw`
++ NCURSESW_LIBS=`${PKG_CONFIG} --libs ncurses`
+ else
+ AS_CASE([$host_os],
+ [darwin*],
@@ -69,8 +67,6 @@ index 1676ec8..73c8be5 100644
# Checks for libraries.
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 7640d21..17a82b7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,4 +37,4 @@ hstr_SOURCES = \
diff --git a/app-shells/hstr/hstr-2.0.ebuild b/app-shells/hstr/hstr-2.0.ebuild
index b2332147a9b4..3c117b21f991 100644
--- a/app-shells/hstr/hstr-2.0.ebuild
+++ b/app-shells/hstr/hstr-2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools
+inherit autotools toolchain-funcs
DESCRIPTION="Shell history suggest box"
HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
@@ -22,12 +22,18 @@ DEPEND="
DOCS=( CONFIGURATION.md README.md )
-PATCHES=( ${FILESDIR}/${P}-fix-ncurses-configure.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-ncurses-configure.patch
+)
src_prepare() {
default
+
sed \
-e 's:-O2::g' \
-i src/Makefile.am || die
+
+ tc-export PKG_CONFIG
+
eautoreconf
}
diff --git a/app-shells/hstr/hstr-2.1.ebuild b/app-shells/hstr/hstr-2.1.ebuild
index 95a0c74991ac..ff38ac472292 100644
--- a/app-shells/hstr/hstr-2.1.ebuild
+++ b/app-shells/hstr/hstr-2.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools
+inherit autotools toolchain-funcs
DESCRIPTION="Shell history suggest box"
HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
@@ -22,12 +22,18 @@ DEPEND="
DOCS=( CONFIGURATION.md README.md )
-PATCHES=( ${FILESDIR}/${PN}-2.0-fix-ncurses-configure.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-fix-ncurses-configure.patch
+)
src_prepare() {
default
+
sed \
-e 's:-O2::g' \
-i src/Makefile.am || die
+
+ tc-export PKG_CONFIG
+
eautoreconf
}
diff --git a/app-shells/hstr/hstr-2.2.ebuild b/app-shells/hstr/hstr-2.2.ebuild
index 08f0c98ba78d..0033ce507cfd 100644
--- a/app-shells/hstr/hstr-2.2.ebuild
+++ b/app-shells/hstr/hstr-2.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools
+inherit autotools toolchain-funcs
DESCRIPTION="Shell history suggest box"
HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
@@ -17,17 +17,24 @@ RDEPEND="
sys-libs/ncurses:0=[unicode]"
DEPEND="
- ${RDEPEND}
- virtual/pkgconfig"
+ ${RDEPEND}"
+
+BDEPEND="virtual/pkgconfig"
DOCS=( CONFIGURATION.md README.md )
-PATCHES=( ${FILESDIR}/${PN}-2.0-fix-ncurses-configure.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-fix-ncurses-configure.patch
+)
src_prepare() {
default
+
sed \
-e 's:-O2::g' \
-i src/Makefile.am || die
+
+ tc-export PKG_CONFIG
+
eautoreconf
}