summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2024-11-17 09:06:17 +0100
committerZac Medico <zmedico@gentoo.org>2024-11-17 11:19:32 -0800
commit99cabffb90adfcedc7034cf71c2ea9e306bee1c1 (patch)
tree071c431123edf574f83aa6a0ac588dd5b635b512 /app-shells
parentpackage.mask: mask usb-robot for removal (diff)
downloadgentoo-99cabffb90adfcedc7034cf71c2ea9e306bee1c1.tar.gz
gentoo-99cabffb90adfcedc7034cf71c2ea9e306bee1c1.tar.bz2
gentoo-99cabffb90adfcedc7034cf71c2ea9e306bee1c1.zip
app-shells/nushell: Fix plugin compilation
Plugins failed to compile when the USE flag 'system-clipboard' was enabled, because for the plugins this Cargo feature does not exist. This fix clears the 'myfeatures' variable and configures again before the plugins are compiled. Closes: https://bugs.gentoo.org/943627 Signed-off-by: Jonas Frei <freijon@pm.me> Closes: https://github.com/gentoo/gentoo/pull/39347 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/nushell/nushell-0.100.0.ebuild4
-rw-r--r--app-shells/nushell/nushell-0.99.1.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/app-shells/nushell/nushell-0.100.0.ebuild b/app-shells/nushell/nushell-0.100.0.ebuild
index edc57a0cf70d..fcecadb54dc0 100644
--- a/app-shells/nushell/nushell-0.100.0.ebuild
+++ b/app-shells/nushell/nushell-0.100.0.ebuild
@@ -762,6 +762,10 @@ src_compile() {
src_install() {
cargo_src_install
if use plugins ; then
+ # Clear features to compile plugins
+ local myfeatures=()
+ cargo_src_configure
+
cargo_src_install --path crates/nu_plugin_custom_values
cargo_src_install --path crates/nu_plugin_example
cargo_src_install --path crates/nu_plugin_formats
diff --git a/app-shells/nushell/nushell-0.99.1.ebuild b/app-shells/nushell/nushell-0.99.1.ebuild
index f34e0d23df49..c4e3778926b5 100644
--- a/app-shells/nushell/nushell-0.99.1.ebuild
+++ b/app-shells/nushell/nushell-0.99.1.ebuild
@@ -769,6 +769,10 @@ src_compile() {
src_install() {
cargo_src_install
if use plugins ; then
+ # Clear features to compile plugins
+ local myfeatures=()
+ cargo_src_configure
+
cargo_src_install --path crates/nu_plugin_custom_values
cargo_src_install --path crates/nu_plugin_example
cargo_src_install --path crates/nu_plugin_formats