summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2019-09-10 22:57:00 +0200
committerRafael Martins <rafaelmartins@gentoo.org>2019-09-10 22:57:05 +0200
commit96bbe123830aa29e945be757b45c03fe5e0081f5 (patch)
tree82ccd261e5978cf1050b9033bd7aacb28c7479c8 /app-text/blogc/blogc-0.18.0.ebuild
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-96bbe123830aa29e945be757b45c03fe5e0081f5.tar.gz
gentoo-96bbe123830aa29e945be757b45c03fe5e0081f5.tar.bz2
gentoo-96bbe123830aa29e945be757b45c03fe5e0081f5.zip
app-text/blogc: version bump
Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Rafael Martins <rafaelmartins@gentoo.org>
Diffstat (limited to 'app-text/blogc/blogc-0.18.0.ebuild')
-rw-r--r--app-text/blogc/blogc-0.18.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-text/blogc/blogc-0.18.0.ebuild b/app-text/blogc/blogc-0.18.0.ebuild
new file mode 100644
index 000000000000..d5c7c49e8ea5
--- /dev/null
+++ b/app-text/blogc/blogc-0.18.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/blogc/blogc.git"
+ inherit git-r3 autotools
+fi
+
+DESCRIPTION="A blog compiler"
+HOMEPAGE="https://blogc.rgm.io/"
+
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ DEPEND="app-text/ronn"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="git httpd make test"
+
+RDEPEND="
+ git? (
+ dev-vcs/git )
+ !dev-vcs/blogc-git-receiver
+ !www-servers/blogc-runserver"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ test? (
+ git? ( dev-vcs/git )
+ dev-util/cmocka )"
+
+src_prepare() {
+ [[ ${PV} = *9999* ]] && eautoreconf
+ eapply_user
+ default
+}
+
+src_configure() {
+ local myconf=""
+ if [[ ${PV} = *9999* ]]; then
+ myconf+="--enable-ronn"
+ else
+ myconf+="--disable-ronn"
+ fi
+ econf \
+ $(use_enable test tests) \
+ $(use_enable git git-receiver) \
+ $(use_enable make make) \
+ $(use_enable httpd runserver) \
+ --disable-make-embedded \
+ --disable-valgrind \
+ ${myconf}
+}