summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-06-29 12:12:24 +0700
committerJoonas Niilola <juippis@gentoo.org>2022-07-05 12:06:39 +0300
commit379f11d5a39579e75606d13eec3543f1f5e6c061 (patch)
treeae27736f892bf4964e13c0f8614fb8c98ea986d8 /app-text/jo/jo-1.6.ebuild
parentnet-im/ejabberd: amd64 stable wrt bug #856508 (diff)
downloadgentoo-379f11d5a39579e75606d13eec3543f1f5e6c061.tar.gz
gentoo-379f11d5a39579e75606d13eec3543f1f5e6c061.tar.bz2
gentoo-379f11d5a39579e75606d13eec3543f1f5e6c061.zip
app-text/jo: bump to 1.6 and 9999
Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://github.com/gentoo/gentoo/pull/26132 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/jo/jo-1.6.ebuild')
-rw-r--r--app-text/jo/jo-1.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/jo/jo-1.6.ebuild b/app-text/jo/jo-1.6.ebuild
new file mode 100644
index 000000000000..996d861cee82
--- /dev/null
+++ b/app-text/jo/jo-1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools bash-completion-r1
+
+DESCRIPTION="JSON output from a shell"
+HOMEPAGE="https://github.com/jpmens/jo"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jpmens/${PN}"
+else
+ SRC_URI="https://github.com/jpmens/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export bashcompdir=$(get_bashcompdir)
+ default
+}
+
+src_install() {
+ default
+ mv "${D}"$(get_bashcompdir)/jo{.bash,} || die
+}