summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-06 18:05:56 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-06 18:09:25 -0400
commit23f0a897016464965d8071ee778366ea90926fd0 (patch)
tree16ddf32510d20a64dd4b8072544649ffd291f036 /app-text/lesspipe/lesspipe-1.83.ebuild
parentsys-apps/less: move colorization logic to external lesspipe pkg (diff)
downloadgentoo-23f0a897016464965d8071ee778366ea90926fd0.tar.gz
gentoo-23f0a897016464965d8071ee778366ea90926fd0.tar.bz2
gentoo-23f0a897016464965d8071ee778366ea90926fd0.zip
app-text/lesspipe: initial package
This holds the code2color program that historically was shipped as part of the main less package.
Diffstat (limited to 'app-text/lesspipe/lesspipe-1.83.ebuild')
-rw-r--r--app-text/lesspipe/lesspipe-1.83.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/lesspipe/lesspipe-1.83.ebuild b/app-text/lesspipe/lesspipe-1.83.ebuild
new file mode 100644
index 000000000000..a012055cbacf
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-1.83.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="a preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://www-zeuthen.desy.de/~friebel/unix/less/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ !<sys-apps/less-483-r1"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build.
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ dodoc ChangeLog README TODO
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}