summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-11-19 12:37:31 +0100
committerSebastian Pipping <sping@gentoo.org>2020-11-19 12:37:47 +0100
commit46880e201159c42d590f693615374aaa5de6fa10 (patch)
tree51bbb9b2551b18fd28704951ab545cd4b728b80d /app-text/nuspell/nuspell-4.1.0.ebuild
parentdev-cpp/catch: Remove old 2.7.0 and 2.9.1 (diff)
downloadgentoo-46880e201159c42d590f693615374aaa5de6fa10.tar.gz
gentoo-46880e201159c42d590f693615374aaa5de6fa10.tar.bz2
gentoo-46880e201159c42d590f693615374aaa5de6fa10.zip
app-text/nuspell: 4.1.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'app-text/nuspell/nuspell-4.1.0.ebuild')
-rw-r--r--app-text/nuspell/nuspell-4.1.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-text/nuspell/nuspell-4.1.0.ebuild b/app-text/nuspell/nuspell-4.1.0.ebuild
new file mode 100644
index 000000000000..f38131dbab56
--- /dev/null
+++ b/app-text/nuspell/nuspell-4.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/4" # due to libnuspell.so.4
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-libs/icu"
+DEPEND="${RDEPEND}
+ doc? ( app-text/pandoc )
+ test? ( >=dev-cpp/catch-2.3.0:0 )
+ >=dev-libs/boost-1.62[icu,nls]"
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ rm -R external/Catch2/ || die
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}