summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-04 05:09:48 +0000
committerSam James <sam@gentoo.org>2021-01-04 05:14:00 +0000
commit1ac0301cbada7e65752c11f9661d9f31c0e63b48 (patch)
tree2fabbee52a3ebef17f1090b77c12e857b81832b8 /app-text/recode
parentdev-db/unixODBC: Stabilize 2.3.9 s390, #763459 (diff)
downloadgentoo-1ac0301cbada7e65752c11f9661d9f31c0e63b48.tar.gz
gentoo-1ac0301cbada7e65752c11f9661d9f31c0e63b48.tar.bz2
gentoo-1ac0301cbada7e65752c11f9661d9f31c0e63b48.zip
app-text/recode: bump to 3.7.8
We also now BDEPEND on cython for tests. Closes: https://bugs.gentoo.org/729382 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/recode')
-rw-r--r--app-text/recode/Manifest1
-rw-r--r--app-text/recode/recode-3.7.8.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-text/recode/Manifest b/app-text/recode/Manifest
index a667abf16991..08c7ab3c800c 100644
--- a/app-text/recode/Manifest
+++ b/app-text/recode/Manifest
@@ -1,3 +1,4 @@
DIST recode-3.6.tar.gz 1751886 BLAKE2B 94436343969da0ee6d16ed69a211d4f36b7a9cb59ce931ef71cfc1e0f11e5709e67ee1e0bb24f5320e6c7d6d01920a6c4d9edce87ff2c6aaaa8c80e30f3b536d SHA512 68de277ac8cd5f6023bb077b959ab5778a78edac1299d507bab906824080b6f86e9bfcd89169aa474197c2faa9af2ceb1ed272c8dd4d50caef373afa05daed1b
DIST recode-3.7.6.tar.gz 2210564 BLAKE2B 8c99b6d2eb93482785fe7e36063514e4c153516cc8059a9b98fc9f1b08704314b7933390a5fd7921525648ef58e9f995242182b8de23b7db33cbf94383e28f29 SHA512 ababefc445fcc47b6bf9ed640b767aed374bb8ce93cdccb641dd1ba5d298360583dd79070a0bb458f1190a8d6f1ddeb3b04eec34a61305b69def0963cec5843f
+DIST recode-3.7.8.tar.gz 2230154 BLAKE2B 853a53d86a3a3600e5d70a8dc67bab9b0fa7a9dfab79e3f4ae8611f54c955802862689077774f7b21ce360f2d91c65ee238406ffa137a84545157e3a70853f42 SHA512 e6cd9c7d3eb5c179d3f62804018d1d19b71a3fae72b0d76aec730c36e64c50a571cbfda5340ac50244a16ccdd9265f5610deadb8908067c3866fa68cbbf0ac70
DIST recode_3.6-20.debian.tar.gz 341117 BLAKE2B 748ee36b68f1d1501edde23e8afcbd58df70a86745e7c366a27a33496e539dcae11b746fb46767e95ae99b68a18684e3e85c1ea961692ac57ad1a01a895734a7 SHA512 bc586534e77b49da7d387187a8ddb042a12871f87f4f32c818ce7218b7254ac5ba6eccb14aaaf0312579f27958883f2da620016a7049c3af24c8bfba81acc3ef
diff --git a/app-text/recode/recode-3.7.8.ebuild b/app-text/recode/recode-3.7.8.ebuild
new file mode 100644
index 000000000000..9a2c9c81562b
--- /dev/null
+++ b/app-text/recode/recode-3.7.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Convert files between various character sets"
+HOMEPAGE="https://github.com/rrthomas/recode"
+SRC_URI="https://github.com/rrthomas/recode/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+# librecode soname version
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/libiconv"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ if use test ; then
+ has_version -b "dev-python/cython[${PYTHON_USEDEP}]" || return 1
+ fi
+}
+
+src_configure() {
+ tc-export CC LD
+
+ # on solaris -lintl is needed to compile
+ [[ ${CHOST} == *-solaris* ]] && append-libs "-lintl"
+
+ # --without-included-gettext means we always use system headers
+ # and library
+ econf \
+ $(use_enable nls) \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}