summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-11 04:20:24 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-11 04:55:59 -0400
commit82343f7848a7fcf52f949fc83e5a64851eb1b0a3 (patch)
tree0a76445626815ec12d906e25f391ec637c620ac2 /app-text/sgrep/sgrep-1.94a-r1.ebuild
parentapp-text/convertlit: pass -std=gnu89 (diff)
downloadgentoo-82343f7848a7fcf52f949fc83e5a64851eb1b0a3.tar.gz
gentoo-82343f7848a7fcf52f949fc83e5a64851eb1b0a3.tar.bz2
gentoo-82343f7848a7fcf52f949fc83e5a64851eb1b0a3.zip
app-text/sgrep: pass -std=gnu89
Does not build with `clang -std=c2x`, early workaround for when this will become a default. (not actively hunting for these, merely revisiting packages previously looked at for clang16 even if not an issue "yet"). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-text/sgrep/sgrep-1.94a-r1.ebuild')
-rw-r--r--app-text/sgrep/sgrep-1.94a-r1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-text/sgrep/sgrep-1.94a-r1.ebuild b/app-text/sgrep/sgrep-1.94a-r1.ebuild
index eb45eb4f246a..b4a1767756d2 100644
--- a/app-text/sgrep/sgrep-1.94a-r1.ebuild
+++ b/app-text/sgrep/sgrep-1.94a-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="Use structural criteria to grep and index text, SGML, XML and HTML and filter"
HOMEPAGE="https://www.cs.helsinki.fi/u/jjaakkol/sgrep.html"
SRC_URI="ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/${P}.tar.gz"
@@ -22,6 +24,8 @@ src_prepare() {
}
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
econf --datadir="${EPREFIX}"/etc
}