summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya <98194153+ThamognyaKodi@users.noreply.github.com>2022-01-22 01:47:05 +0000
committerJoonas Niilola <juippis@gentoo.org>2022-02-15 08:52:39 +0200
commit3fe0eafb006e445dd7c70e51871f2e98ad7c63c3 (patch)
tree9ad79b4d0af4c073d4d14efc63344c27b01e3dc6 /app-text
parentapp-text/zathura-cb: Bump to version 0.1.9 (diff)
downloadgentoo-3fe0eafb006e445dd7c70e51871f2e98ad7c63c3.tar.gz
gentoo-3fe0eafb006e445dd7c70e51871f2e98ad7c63c3.tar.bz2
gentoo-3fe0eafb006e445dd7c70e51871f2e98ad7c63c3.zip
app-text/zathura-ps: bump to 0.2.7 version
Signed-off-by: Thamognya Kodi <thamognyak@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23906 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura-ps/Manifest1
-rw-r--r--app-text/zathura-ps/zathura-ps-0.2.7.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-text/zathura-ps/Manifest b/app-text/zathura-ps/Manifest
index eba030e6d419..46759bd2c04a 100644
--- a/app-text/zathura-ps/Manifest
+++ b/app-text/zathura-ps/Manifest
@@ -1 +1,2 @@
DIST zathura-ps-0.2.6.tar.xz 4336 BLAKE2B 9129ae5c5b6b7452fbee720ded0a69d4ae735811b81ec49485fffc81833e5e0adf0563b005770082adcc17dc90d4650b5bd309154b64377625c2cef86f0b7978 SHA512 6631f9b1c951b6f91f2a5217c3de47176205102206f15b596fb21285dae8d01fd759cfaca1b8a23bf47166dfbc3f8cf6061ce5a4d7a1c3a2b671a3beef5a07bb
+DIST zathura-ps-0.2.7.tar.xz 4488 BLAKE2B 4513173a2f9ca725abf8444516a78fd789286b082a1146ab5d0dee504cdda92962f3e6cef46f24e0307bc5ea6bb6595577fac2dfbd2d4ef0cf8e69d34337baf5 SHA512 86cf4cea8f32e446960c7727745711d6bb6723bb41127ccba335fbdaeb78e9f681ce4104b2be8718a2f19e06aef30d49ae7c90091fa0774b5ffe22303cf37d5f
diff --git a/app-text/zathura-ps/zathura-ps-0.2.7.ebuild b/app-text/zathura-ps/zathura-ps-0.2.7.ebuild
new file mode 100644
index 000000000000..52b16b0f9b8d
--- /dev/null
+++ b/app-text/zathura-ps/zathura-ps-0.2.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-ps.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://pwmt.org/projects/zathura-ps/download/${P}.tar.xz"
+fi
+
+DESCRIPTION="PostScript plug-in for zathura"
+HOMEPAGE="https://pwmt.org/projects/zathura-ps/download/"
+
+LICENSE="ZLIB"
+SLOT="0"
+
+DEPEND="app-text/libspectre
+ >=app-text/zathura-0.3.9
+ dev-libs/girara
+ dev-libs/glib:2
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}