summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2021-06-04 15:37:12 -0400
committerMike Frysinger <vapier@gentoo.org>2021-06-04 15:39:02 -0400
commit43d663de10b438732b69882326a7088f5e07cad9 (patch)
treeec718b7e2f04c3ebc1094a59a3dac952cc597ee4 /app-text
parentdev-ada/aws: drop support for gnat_2016 (diff)
downloadgentoo-43d663de10b438732b69882326a7088f5e07cad9.tar.gz
gentoo-43d663de10b438732b69882326a7088f5e07cad9.tar.bz2
gentoo-43d663de10b438732b69882326a7088f5e07cad9.zip
app-text/tidy-html5: fix self linkage
Don't statically link the libtidy library into the tidy program. This saves a lot of space. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/tidy-html5/tidy-html5-5.7.28-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/tidy-html5/tidy-html5-5.7.28-r1.ebuild b/app-text/tidy-html5/tidy-html5-5.7.28-r1.ebuild
new file mode 100644
index 000000000000..f3f78ced3cec
--- /dev/null
+++ b/app-text/tidy-html5/tidy-html5-5.7.28-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Tidy the layout and correct errors in HTML, HTML5 and XML documents"
+HOMEPAGE="https://www.html-tidy.org/"
+SRC_URI="https://github.com/htacg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="!app-text/htmltidy"
+
+DOCS=( README/{CODESTYLE,CONTRIBUTING,LICENSE,VERSION}.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DTIDY_CONSOLE_SHARED=yes
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+ cmake_src_configure
+}