summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-11 17:06:53 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-12 15:36:03 +0100
commit50a58c6a975f13f0a1ae24480ab2623fcef10f09 (patch)
treea249f36c4a9978825a2374559de92e5da437620e /app-text
parentMove {app-doc → app-text}/halibut (diff)
downloadgentoo-50a58c6a975f13f0a1ae24480ab2623fcef10f09.tar.gz
gentoo-50a58c6a975f13f0a1ae24480ab2623fcef10f09.tar.bz2
gentoo-50a58c6a975f13f0a1ae24480ab2623fcef10f09.zip
Move {app-doc → app-text}/psmark
Per the category metadata, app-doc/ is reserved for documentation *files* and not software. Move it to app-text/ where it seems a better fit. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/psmark/Manifest1
-rw-r--r--app-text/psmark/files/psmark-2.1-Makefile-QA.patch19
-rw-r--r--app-text/psmark/files/psmark-2.1-string.patch15
-rw-r--r--app-text/psmark/metadata.xml10
-rw-r--r--app-text/psmark/psmark-2.1.ebuild33
5 files changed, 78 insertions, 0 deletions
diff --git a/app-text/psmark/Manifest b/app-text/psmark/Manifest
new file mode 100644
index 000000000000..c22a67413f94
--- /dev/null
+++ b/app-text/psmark/Manifest
@@ -0,0 +1 @@
+DIST psmark-v2.1.tar.gz 16296 BLAKE2B e4f77b7a3abd86f8214e2f00d85eaef4a7b897b3fad970cf86565ad32ab42e25ab7674e9a1a7116a4cce93f46a99a5d17a21c14fb4ff3b2a860e1e2627b268a7 SHA512 0a765dda878478e767ae02ac0838a9c36a110000b35d557b1b3d17d22c518f42249cd4eba856b476ba8042e026cb49f736077d3bf236f2a9a4f3df4ff4357fef
diff --git a/app-text/psmark/files/psmark-2.1-Makefile-QA.patch b/app-text/psmark/files/psmark-2.1-Makefile-QA.patch
new file mode 100644
index 000000000000..145fe3a32e8e
--- /dev/null
+++ b/app-text/psmark/files/psmark-2.1-Makefile-QA.patch
@@ -0,0 +1,19 @@
+--- a/Makefile
++++ b/Makefile
+@@ -3,14 +3,13 @@
+ all:
+ make clean
+ make psmark
+
+ psmark:
+- gcc $(CFLAGS) -o psmark psmark.c
+- strip psmark
++ $(CC) $(CFLAGS) $(LDFLAGS) -o psmark psmark.c
+
+ clean:
+ rm -f *.o psmark
+
+ install:
+- install -s psmark /usr/bin/
++ install psmark /usr/bin/
+ install psmark.1 /usr/man/man1/
diff --git a/app-text/psmark/files/psmark-2.1-string.patch b/app-text/psmark/files/psmark-2.1-string.patch
new file mode 100644
index 000000000000..1d1fb3dfbb57
--- /dev/null
+++ b/app-text/psmark/files/psmark-2.1-string.patch
@@ -0,0 +1,15 @@
+--- a/psmark.c
++++ b/psmark.c
+@@ -97,9 +97,9 @@
+ progname);
+ fprintf(stderr,"example:\n %s -i test.ps -o output.ps -b 0.4 -s 15 \"vertical label\""
+ "\n\n",progname);
+- fprintf(stderr,"Notes: The offsets are measured from the bottom left hand corner, but
+- they are not in sync with the page corner: some fiddling is required
+- to get text to appear right in the corner.\n"
++ fprintf(stderr,"Notes: The offsets are measured from the bottom left hand corner, but\n"
++ "they are not in sync with the page corner: some fiddling is required\n"
++ "to get text to appear right in the corner.\n"
+ );
+
+ exit(error ? EXIT_FAILURE : EXIT_SUCCESS);
diff --git a/app-text/psmark/metadata.xml b/app-text/psmark/metadata.xml
new file mode 100644
index 000000000000..ecbed5b5dce7
--- /dev/null
+++ b/app-text/psmark/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ Command-line Postscript watermark tool; simple, but useful for things
+ like adding a watermark to outgoing or incoming faxes (eg, use with the
+ sendfax command from net-misc/hylafax).
+ </longdescription>
+</pkgmetadata>
diff --git a/app-text/psmark/psmark-2.1.ebuild b/app-text/psmark/psmark-2.1.ebuild
new file mode 100644
index 000000000000..8d8d4e7fd704
--- /dev/null
+++ b/app-text/psmark/psmark-2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PN=${PN}-v
+MY_P=${MY_PN}${PV}
+
+DESCRIPTION="Prints watermark-like text on any PostScript document"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://www.antitachyon.com/download/${MY_P}.tar.gz"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-string.patch
+ "${FILESDIR}"/${P}-Makefile-QA.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin psmark
+ doman psmark.1
+ dodoc README CHANGELOG
+}