summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-12-11 17:11:32 -0600
committerFlorian Schmaus <flow@gentoo.org>2023-12-13 08:50:10 +0100
commit785b732be3914227b8455af1a69dcb15ad781ab6 (patch)
tree7669816bdc273471e13a30d01e2c6f064dd227bb /app-text
parentnet-misc/passt: User-mode networking daemons for VMs and namespaces (diff)
downloadgentoo-785b732be3914227b8455af1a69dcb15ad781ab6.tar.gz
gentoo-785b732be3914227b8455af1a69dcb15ad781ab6.tar.bz2
gentoo-785b732be3914227b8455af1a69dcb15ad781ab6.zip
app-text/rman: update EAPI 7 -> 8, fix -Wincompatible-pointer-types
Closes: https://bugs.gentoo.org/880523 Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/34244 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/rman/files/rman-3.2-incompatible-pointer-types.patch24
-rw-r--r--app-text/rman/rman-3.2-r2.ebuild32
2 files changed, 56 insertions, 0 deletions
diff --git a/app-text/rman/files/rman-3.2-incompatible-pointer-types.patch b/app-text/rman/files/rman-3.2-incompatible-pointer-types.patch
new file mode 100644
index 000000000000..bb7645c23f34
--- /dev/null
+++ b/app-text/rman/files/rman-3.2-incompatible-pointer-types.patch
@@ -0,0 +1,24 @@
+From 1120713781a5da03a56d3f8d59904c0fd20f6dd6 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Leonardo=20Hern=C3=A1ndez=20Hern=C3=A1ndez?=
+ <leohdz172@proton.me>
+Date: Mon, 11 Dec 2023 17:05:26 -0600
+Subject: [PATCH] fix build with -Werror=incompatible-pointer-types
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me>
+--- a/rman.c
++++ b/rman.c
+@@ -268,7 +268,7 @@ stricmp(const char *s1, const char *s2) {
+ else return 1;
+ }
+
+-int lcexceptionscmp(const char **a, const char **b) { return stricmp(*a, *b); }
++int lcexceptionscmp(const void *a, const void *b) { return stricmp((const char *)a, (const char *)b); }
+
+ int
+ strincmp(const char *s1, const char *s2, size_t n) {
+--
+2.43.0
+
diff --git a/app-text/rman/rman-3.2-r2.ebuild b/app-text/rman/rman-3.2-r2.ebuild
new file mode 100644
index 000000000000..a6e49555a341
--- /dev/null
+++ b/app-text/rman/rman-3.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="PolyGlotMan man page translator AKA RosettaMan"
+HOMEPAGE="https://sourceforge.net/projects/polyglotman/"
+SRC_URI="mirror://sourceforge/polyglotman/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-incompatible-pointer-types.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}