summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2021-09-10 15:09:56 +0000
committerIonen Wolkens <ionen@gentoo.org>2021-09-12 17:07:34 -0400
commit8886953c6a3e20a2b3eed91da17c97f0790ba71f (patch)
tree95f4cdec51ba05b6a276429cb26f0f7a4c014f83 /app-text
parentx11-libs/pango: restore 1.48.5-r1 for circular dep workaround (diff)
downloadgentoo-8886953c6a3e20a2b3eed91da17c97f0790ba71f.tar.gz
gentoo-8886953c6a3e20a2b3eed91da17c97f0790ba71f.tar.bz2
gentoo-8886953c6a3e20a2b3eed91da17c97f0790ba71f.zip
app-text/zathura-djvu: use xdg eclass
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura-djvu/zathura-djvu-0.2.9.ebuild12
-rw-r--r--app-text/zathura-djvu/zathura-djvu-9999.ebuild12
2 files changed, 2 insertions, 22 deletions
diff --git a/app-text/zathura-djvu/zathura-djvu-0.2.9.ebuild b/app-text/zathura-djvu/zathura-djvu-0.2.9.ebuild
index c80464b43d7a..392cfe24b681 100644
--- a/app-text/zathura-djvu/zathura-djvu-0.2.9.ebuild
+++ b/app-text/zathura-djvu/zathura-djvu-0.2.9.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson xdg-utils
+inherit meson xdg
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -28,13 +28,3 @@ RDEPEND="app-text/djvu
DEPEND="${RDEPEND}
virtual/pkgconfig"
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
diff --git a/app-text/zathura-djvu/zathura-djvu-9999.ebuild b/app-text/zathura-djvu/zathura-djvu-9999.ebuild
index 903624bd13ce..8b3af5827a64 100644
--- a/app-text/zathura-djvu/zathura-djvu-9999.ebuild
+++ b/app-text/zathura-djvu/zathura-djvu-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit gnome2-utils meson xdg-utils
+inherit meson xdg
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -28,13 +28,3 @@ RDEPEND="app-text/djvu
DEPEND="${RDEPEND}
virtual/pkgconfig"
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}