summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-11-05 18:35:22 -0500
committerZac Medico <zmedico@gentoo.org>2023-11-08 08:26:38 -0800
commitcd482d64b5777de2eda8d32168194f076fe4ee03 (patch)
treed9bfa3d35b693be0f968de8f07dd4af0ac382ad1 /app-text
parentapp-text/calibre: add USE dependency for unrar-based ebooks (diff)
downloadgentoo-cd482d64b5777de2eda8d32168194f076fe4ee03.tar.gz
gentoo-cd482d64b5777de2eda8d32168194f076fe4ee03.tar.bz2
gentoo-cd482d64b5777de2eda8d32168194f076fe4ee03.zip
app-text/calibre: use modern xdg pkg_* approach
We inherit xdg and let it take care of defining these phases, rather than inheriting a low-level eclass and manually performing it. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/calibre-6.29.0.ebuild14
1 files changed, 1 insertions, 13 deletions
diff --git a/app-text/calibre/calibre-6.29.0.ebuild b/app-text/calibre/calibre-6.29.0.ebuild
index d6c474831e8c..7d036b7860fd 100644
--- a/app-text/calibre/calibre-6.29.0.ebuild
+++ b/app-text/calibre/calibre-6.29.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="sqlite,ssl"
-inherit edo toolchain-funcs python-single-r1 qmake-utils verify-sig xdg-utils
+inherit edo toolchain-funcs python-single-r1 qmake-utils verify-sig xdg
DESCRIPTION="Ebook management application"
HOMEPAGE="https://calibre-ebook.com/"
@@ -241,15 +241,3 @@ src_install() {
newinitd "${FILESDIR}"/calibre-server-3.init calibre-server
newconfd "${FILESDIR}"/calibre-server-3.conf calibre-server
}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- xdg_icon_cache_update
-}