summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-18 19:50:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-21 23:19:53 +0100
commitddbee9fb70bac9df89a6afceebb3d91096888eed (patch)
tree67bad355d70e07b0b1df9470e4c08f2cb457ff4b /app-text
parentapp-office/libreoffice-bin-debug: add 7.5.8.2 (diff)
downloadgentoo-ddbee9fb70bac9df89a6afceebb3d91096888eed.tar.gz
gentoo-ddbee9fb70bac9df89a6afceebb3d91096888eed.tar.bz2
gentoo-ddbee9fb70bac9df89a6afceebb3d91096888eed.zip
app-text/poppler: Add IUSE qt6
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/poppler-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index aaa749ef674e..13bad1057cc7 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -25,7 +25,7 @@ DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
HOMEPAGE="https://poppler.freedesktop.org/"
LICENSE="GPL-2"
-IUSE="boost cairo cjk curl +cxx debug doc gpgme +introspection +jpeg +jpeg2k +lcms nss png qt5 test tiff +utils"
+IUSE="boost cairo cjk curl +cxx debug doc gpgme +introspection +jpeg +jpeg2k +lcms nss png qt5 qt6 test tiff +utils"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
@@ -49,6 +49,7 @@ COMMON_DEPEND="
dev-qt/qtgui:5
dev-qt/qtxml:5
)
+ qt6? ( dev-qt/qtbase:6[gui,xml] )
tiff? ( media-libs/tiff:= )
"
RDEPEND="${COMMON_DEPEND}
@@ -56,10 +57,13 @@ RDEPEND="${COMMON_DEPEND}
"
DEPEND="${COMMON_DEPEND}
boost? ( >=dev-libs/boost-1.71 )
- test? ( qt5? (
- dev-qt/qttest:5
- dev-qt/qtwidgets:5
- ) )
+ test? (
+ qt5? (
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ )
+ qt6? ( dev-qt/qtbase:6[test,widgets] )
+ )
"
BDEPEND="
>=dev-util/glib-utils-2.64
@@ -131,9 +135,9 @@ src_configure() {
-DENABLE_NSS3=$(usex nss)
-DWITH_PNG=$(usex png)
-DENABLE_QT5=$(usex qt5)
+ -DENABLE_QT6=$(usex qt6)
-DENABLE_LIBTIFF=$(usex tiff)
-DENABLE_UTILS=$(usex utils)
- -DENABLE_QT6=OFF
)
use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )