summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/ctrlp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/ctrlp')
-rw-r--r--app-vim/ctrlp/Manifest2
-rw-r--r--app-vim/ctrlp/ctrlp-1.78.ebuild20
-rw-r--r--app-vim/ctrlp/ctrlp-1.79.ebuild19
-rw-r--r--app-vim/ctrlp/metadata.xml8
4 files changed, 49 insertions, 0 deletions
diff --git a/app-vim/ctrlp/Manifest b/app-vim/ctrlp/Manifest
new file mode 100644
index 000000000000..ebc200d060f3
--- /dev/null
+++ b/app-vim/ctrlp/Manifest
@@ -0,0 +1,2 @@
+DIST ctrlp-1.78.tar.gz 41117 SHA256 ec11362c2e443a8b9d8b8ee38a1fcc7a6633b4a5fe9a10611b1d390d24230aa2 SHA512 a98073364cad828c8ccf381e23dd45be44399b021c6172296e77513d1ba41a4f41e0640809eace3bf7610036237a18d7e1986069f788c9d0a2d1ef6484a16a6c WHIRLPOOL 686311bd2399441febd52f4f2bcdc95e95b876c53e3fda900ecaff3fc1b43fb8fd7c08cf78beb9659c254ae499c28ab7b27b73dcea6d382f0e0933f5a37aa77b
+DIST ctrlp-1.79.tar.gz 45605 SHA256 2c1404d059d2ae4c3bf42a992108265fbe0e825c21a49db9411cba6a28cd4dc9 SHA512 6967db0fa6b60317794c0ba0ab6ef04f63c059c30a74af56c460bbc44a4756f11540b45dddcdd5da1d0eb47943682ef3fff64a9a14ea0ba3a73a1e0c42f051e6 WHIRLPOOL bde28ff592842b1c9269c4317c731c494829fc6f753310eed69dec4359d81d0dcf5a63819f22fb4451c3a16e52fd70434a63cd03ef141ea3e69d9f788c7bf722
diff --git a/app-vim/ctrlp/ctrlp-1.78.ebuild b/app-vim/ctrlp/ctrlp-1.78.ebuild
new file mode 100644
index 000000000000..093da6bddc60
--- /dev/null
+++ b/app-vim/ctrlp/ctrlp-1.78.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin vcs-snapshot
+
+DESCRIPTION="vim plugin: fuzzy file, buffer, mru, tag, ... finder with regex support"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3736 http://kien.github.com/ctrlp.vim/"
+SRC_URI="https://github.com/kien/ctrlp.vim/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ rm .gitignore readme.md || die
+}
diff --git a/app-vim/ctrlp/ctrlp-1.79.ebuild b/app-vim/ctrlp/ctrlp-1.79.ebuild
new file mode 100644
index 000000000000..60602f0857bc
--- /dev/null
+++ b/app-vim/ctrlp/ctrlp-1.79.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin vcs-snapshot
+
+DESCRIPTION="vim plugin: fuzzy file, buffer, mru, tag, ... finder with regex support"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3736 http://kien.github.com/ctrlp.vim/"
+SRC_URI="https://github.com/kien/ctrlp.vim/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ rm readme.md || die
+}
diff --git a/app-vim/ctrlp/metadata.xml b/app-vim/ctrlp/metadata.xml
new file mode 100644
index 000000000000..00b6952806c9
--- /dev/null
+++ b/app-vim/ctrlp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">kien/ctrlp.vim</remote-id>
+ </upstream>
+</pkgmetadata>